Unexpectedly closed the connection

My deploy previews have suddenly stopped working. Clicking the link takes me to a page that has the error ERR_CONNECTION_CLOSED. This happens on all branches. Oddly deploying a preview to production works fine, but opening the production preview also has the same problem.

Not sure what caused it, other than possibly setting my repo to private and then back to public again.

I’ve tried:

  • Unlinking, and relinking the repo.
  • Waiting 24h to see if it was a service issue.
  • Clearing the cache and retrying build.
  • Closing and reopening the related PR.

Which site is this about?

Hey there, this is regarding www.gamesrightmeow.com.

Hi, @gamesrightmeow. I am not seeing any connection errors when I test.

Would you be willing to make a HAR recording of the issue occurring?

To clarify, the issue isn’t with live production deploys (so www.gamesrightmeow.com is fine) but with preview deploys. For example, this deploy has the ERR_CONNECTION_CLOSED issue: https://deploy-preview-8--games-right-meow.netlify.app/

I can’t seem to attached files as a new user, so here’s the contents of the HAR file:

{
  "log": {
    "version": "1.2",
    "creator": {
      "name": "WebInspector",
      "version": "537.36"
    },
    "pages": [],
    "entries": [
      {
        "_initiator": {
          "type": "other"
        },
        "_priority": "VeryHigh",
        "_resourceType": "document",
        "cache": {},
        "request": {
          "method": "GET",
          "url": "https://deploy-preview-8--games-right-meow.netlify.app/",
          "httpVersion": "",
          "headers": [
            {
              "name": "Referer",
              "value": "https://github.com/GamesRightMeow/GamesRightMeow.github.io/pull/8"
            },
            {
              "name": "Upgrade-Insecure-Requests",
              "value": "1"
            },
            {
              "name": "User-Agent",
              "value": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/116.0.0.0 Safari/537.36"
            },
            {
              "name": "sec-ch-ua",
              "value": "\"Chromium\";v=\"116\", \"Not)A;Brand\";v=\"24\", \"Google Chrome\";v=\"116\""
            },
            {
              "name": "sec-ch-ua-mobile",
              "value": "?0"
            },
            {
              "name": "sec-ch-ua-platform",
              "value": "\"Windows\""
            }
          ],
          "queryString": [],
          "cookies": [],
          "headersSize": -1,
          "bodySize": 0
        },
        "response": {
          "status": 0,
          "statusText": "",
          "httpVersion": "",
          "headers": [],
          "cookies": [],
          "content": {
            "size": 0,
            "mimeType": "x-unknown"
          },
          "redirectURL": "",
          "headersSize": -1,
          "bodySize": -1,
          "_transferSize": 0,
          "_error": "net::ERR_CONNECTION_CLOSED"
        },
        "serverIPAddress": "",
        "startedDateTime": "2023-09-22T15:44:48.076Z",
        "time": 35.9760000001188,
        "timings": {
          "blocked": 35.9760000001188,
          "dns": -1,
          "ssl": -1,
          "connect": -1,
          "send": 0,
          "wait": 0,
          "receive": 0,
          "_blocked_queueing": -1
        }
      }
    ]
  }
}

Your website appears to work fine:

Does it work on a different network or a VPN?

Oh weird, you’re right. The deploy preview works fine on my phone’s cellular network, but my office network still results in the same issue :thinking:

I believe that makes it a problem on my end, tho right now I’m not quite sure what’s going on :sweat_smile:

Hi, @gamesrightmeow. My best guess is that a security application on your office network as incorrectly flagged the deploy preview URLs as something that should be blocked. The administrator of that network should be able to confirm this and remove the block.

​Please let us know if there are other questions about this.

Thanks, but unfortunately I am the administrator since this is a home network :sweat_smile:

I’ve confirmed this is an issue on all devices on my network, even ones that I wasn’t previously using to view the deploy preview, so I’m fairly certain this is an issue with my router or modem. However, I haven’t made any intentional network changes, so I’m not quite sure what to look for. I’ve already tried resetting both my router and my modem, but no luck. Checking the firewall logs also didn’t turn up any events blocking the deploy preview.

Can you recommend any other settings/things to check?

EDIT: I did another test by connecting to the wifi network on my router, and also directly to wifi network on my Xfinity provided gateway. Both have the same issue, so I think it’s a problem with the Xfinity gateway. I used the Xfinity connectivity tester in the gateway’s dashboard, and this seems to confirm the problem…but I’m unsure how to address this.

I know this isn’t a problem on Netlify’s end, but if anyone has any recommendations, it would be greatly appreciated!

Turned out to be Xfinity’s Advanced Security feature which got auto enabled in an automatic firmware update :upside_down_face: Turning it off fixed my problem.