Unable to deploy background functions even though I am on Pro plan ( URGENT )

Hi, I recently bought Pro plan ( 1st month is free ) for using background functions although, upon deploying, I get the error saying I can’t deploy background functions as I am not on Pro plan. Can someone please look into this? It is a bit urgent as we are planning to launch today. Thank you!

Can someone please provide support?

@ayezinzu If you’re on a Pro plan you can lodge a support ticket here:

The forum may provider a faster response though, just be aware that the bulk of Netlify’s staff don’t work weekends, so it’s easier to get support midweek.

@nathanmartin I am on Pro plan but it says I don’t have permission to view the page.

@ayezinzu I understand your issue, there’s no need to provide more detail to me, as I’m not Netlify staff member and cannot assist you.

I’m just letting you know you’ll need to be patient, as it’s currently the weekend.

Hi @ayezinzu, background functions aren’t automatically enabled on the Pro trail. Can you provide details on your use case for background functions?

@sid.mann

Hi I am using Netlify as a middleware to get data from an authorised external api. Sometimes the call takes longer than 10 seconds and the normal function times out after 10 seconds thus resulting with an error. I assume that won’t be the case with background functions as they have a runtime of 10 minutes

Hi @sid.mann requesting to escalate this. Like I mentioned we are quite behind scheduled for our launch and this is the only thing that is blocking us right now. I would really appreciate if this issue is escalated. Thank you :pray:

Hi @ayezinzu, I’ve increased your function timeout to 26 seconds, in the case that they take longer than 10 seconds to run but less than 26 seconds. Can you redeploy your site and let me know if that solves your issue?

This might partially solve it although if I could have background functions then I will have a really big safety net of 15 mintues. Sometimes the API does take a bit to respond. I hope you understand my issue. Thank you! @sid.mann