Trying Simplest Netlify Identity example; Login/Sign-up UI appears in local, not in production

I am trying to set-up the simplest Identity example. I have enabled Identity for the project. Using Netlify-cli in local dev environment, after adding Identity script, I do see, the sign-up/login UI appearing.

On trying to sign-up, I do get the sign-up email successfully. However, clicking the authentication link in the sign-up, it takes me to the production deployment where Identlity script was not yet pushed.

I tried pushing the changes and deploy them to Netlify to see if it works there (although wanted this cycle to complete in local dev environment, may be a future enhancement for Netlify-cli dev + Identity).

On pushing the minimal code to production, I don’t see the login/signup pop-up appearing on the UI, but a gray-overlay appears in the netlify deployed url -

Any help appreciated on what I might be missing to make this work.

Try moving the identity widget script to the <head> of your page, so you’re sure it’s loaded before the open function is called.

Thanks @tomrutgers - That didn’t helped

However, when I tried to load the login/sign-up page just using the Netlify Identity attribute - data-netlify-identity-button , it worked.

Thanks a lot for you help.

1 Like