[Support Guide] I’ve deployed my site but I still see "Page not found”

hi there, did you read the guide on resolving this issue?

yes but i do not understand what i must do can you explain it to me like a baby

Netlify Site Name: https://discordvuejs.netlify.app/
Still having “page not found”

Also did:
checked build command
checked publish directory

Hi, @YousefAbood. We would be happy to troubleshoot and explain more about why this is happening. Would you please send us a link to the non-working site?

@flityzz, your site doesn’t have any HTML files in the deploy directory. For example, there is the following javascript file:


but there isn’t any index.html. Are you building a static version of your site or does your site require a node application server to work?

I am having the same issue of page not found even though I have index.html file in the root folder.
url: https://d4w.netlify.app

I have solved the issue, I was using Github to display the page but i only needed to put the rootfolder

3 posts were merged into an existing topic: Build stuck at building phase. Not deploying

i’m building a static version. I’m using webpack for it, dont know why my dist folder doesnt have the index.html file, i will let to you my build script in package.json to see if im doing wrong

“build”: “cross-env NODE_ENV=production webpack --progress --hide-modules”

Hi, @devs4web. That site is working when I test:

$ curl -svo /dev/null https://d4w.netlify.app/  2>&1 | egrep '^(\* Connected|(<|>) )'
* Connected to d4w.netlify.app ( port 443 (#0)
> GET / HTTP/2
> Host: d4w.netlify.app
> User-Agent: curl/7.64.1
> Accept: */*
< HTTP/2 200
< cache-control: public, max-age=0, must-revalidate
< content-type: text/html; charset=UTF-8
< date: Mon, 05 Oct 2020 23:40:58 GMT
< etag: "c00dabd5e4aaeeda89c481121447d7de-ssl"
< link: <https://www.devs4web.com/>; rel="canonical"
< strict-transport-security: max-age=31536000; includeSubDomains; preload
< age: 0
< server: Netlify
< x-nf-request-id: 3440924b-ca2e-42bc-81ec-cf3401bc6eb0-1557898

If it isn’t working for you, would you please send us the x-nf-request-id header for the response that doesn’t work for you (that header or the information is replaces)? For example, the value for my request above is 3440924b-ca2e-42bc-81ec-cf3401bc6eb0-1557898.

@YousefAbood, thank you for the follow-up to let us know it is working now.

@flityzz, the repo is public for that site and I can see the build creates three files, none of which is an HTML file. Are you trying to run a server at Netlify? If so, that does work and there is more information about why here:

If you are trying to run a server, you might be able to use Functions for this purpose. That depends one what the purpose of the javascript file is (and I don’t know what that purpose is). Can you tell us more about that?

If you are not trying to run a server, where are the HTML files for this site? Again, as above, what is the purpose of the build.js file? How does it tie in with other files to make a website?

sorry @luke i don’t understood exacly what you are asking :d, i’m a beginner but i found the exacly the same issue in the stack overflow that describes very well my doubt Stack Overflow Question I did what the answer said but doenst worked.

Hi, @flityzz. I don’t know the answer either to be honest. Our support team has a limited scope of support for the assistance that we provide. I mention this because while our support team cannot troubleshoot the site code itself (which is third-party code), someone else here on the community site might. Our support team can troubleshoot Netlify specific issues but not third-party code issues. We could troubleshoot if the issue was caused by Netlify but that isn’t the case here.

Again, I want to be clear that your question is welcome even if our support team won’t be able to answer it. The answer in that Stack Overflow post appears to be written by the illustrious @talves so maybe he will have input into your example as well.

The site itself no longer exists I see. I believe the repository for this site is public isn’t it @flityzz? If so, you might also post the repo URL here for others to look at.

1 Like

@flityzz you should start with: vue create hello-world

This will show you how a vue project gets scaffold to include all your assets into a dist folder on build. You should be able to pick most of the default options to get a clean project.


@luke Thanks for the reply, here is my repository: https://github.com/flityzz/discord-vue

As @talves said, I should have started my project with ‘vue create [project]’, instead I created it with ‘vue webpack-simple’. The Vue webpack-simple template does not create a finished build folder. It assumes you will be hosting your site from the root of the project. so thanks anyways for the replies

UPDATE: actually, your stack overflow answer worked! thanks, i was forgetting to commit the netlify.toml file to the repository, so i added the file and it worked! thanks @luke and @talves

@talves deserves all the credit on this one! :+1:

1 Like

A post was split to a new topic: Page not found for route “/login”

A post was split to a new topic: How do I make the site subdomain netlify.com and not netlify.app

2 posts were split to a new topic: “Page not found” for ‘nuxt build’ command (‘nuxt export’ possibly needed)

Hi everyone,
I need help because Netlify says Site is live but cannot find it. I have read your suggestions above and downloaded a copy of the deploy but cannot read anything from there (because I am not familiar with this process) can you help me to find the website please?

@mathieujulien99 Welcome to the Netlify community.

Please provide your Netlify site name, domains, and other information when you post. The better the post = the faster we can help!

Site name: Island Tribes Challenges
Site domain: islandtribeschallenges.com
URL: https://www.islandtribeschallenges.com/