[Support Guide] I’ve deployed my site but I still see "Page not found”

@mathieujulien99 OK, after your download a copy of your deploy, you will find a file called something like deploy-5f6fafe4f8986e0008994f3d.zip.

You unZIP this file (AKA unarchive), which typically can be done by double-clicking it. This will result in a new folder in the same directory as the ZIP file with the same name as the ZIP file, but without the .zip file extension.

Open the new folder.

Inside, you should see your site files. If you see only another folder, or a bunch of files without one named index.html, that’s your problem. You MUST have an index.html file at the top level of your site for your site to load when people visit your domain URL.

If your main index.html file is inside a folder, you need to figure out how to build / deploy your site so that your site files, including especially your main index.html file, are at the top level, not hidden inside a folder.

If you see only a folder inside your site folder, you should be able to see your site by going to https://www.islandtribeschallenges.com/foldername/.

Hi Greg, thank you for your help and patience.
I have followed your instructions carefully.
But I don’t receive the index.html among the other folders when download the zip file,
and this even when I do other deploy trials with other templates.

mathieujulien99 Then you know what you need to fix. Somehow, you need your build process to generate an index.html file at the top level of your website.

1 Like

domain: https://sixtomidnight.productions

I’m using a branch deploy of staging to test out a the example form element and on submit it’s hitting me with “404 page not found”… Does the form need to be on the production branch?

no, forms can be on any branch, this is likely resulting from something else.

Do you have an index page for that domain?

domain : nervous-curie-686902.netlify.app

The build works on my computer but it doesn’t on Netlify

Hey there, thanks for reaching out.

What you are describing sounds a bit like a an issue with case sensitivity on our system.

Can you give this a read through and let us know if that fixes the issue?

I’m having this same problem. I’ve written a React application. I have an index.html file in my public folder which is where I set the publish directory. Deploy says successful but I get 404. netlify.toml has rewrite as shown in docs. Help please :slight_smile: thanks!

Ok, now I am not getting the page not found message, but I get a blank screen. This is not making any sense. Builds fine locally. I’ve changed my file structure(which is why I’m not getting page not found anymore) but still no joy.

Hello, if anyone can help that will be amazing, i still new to netlify and when i do get the error page not found but it says website have been published. I did go over the information on how to debug that but still, i am currently struggling, also when i try to download the zip file it throws an error that it can’t download the zip file. please help. thanks

Thanks, You really save me!

Hey there, I use React Router to switch between all my pages. Using localhost, everything works as expected. However, when deployed to Netlify, I get a 404 error if I open any url other than the home url by pasting it in the browser, or if I refresh any page except the home page. Navigating the site from the home page works fine. Any ideas what could be causing this?

The entire page is being rendered and routed client side.


The _redirect method regarding index.html worked, and react router works perfectly on custom URLs and refreshing.


Hi Pie,

My forms on itsasecretmedspa.netlify.app were working up until yesterday night but now it’s throwing a ‘page not found’. I’m not sure what’s wrong, all I added to my static site were Google Maps and another form.

Can you help me please?

Thank you!

Looks like you sorted this out :slight_smile:

Actually I haven’t gotten a good solution for this. I have to hard code the into every index page that has a form on my site and I have to do it every time I deploy a new build. Also, I had to make more changes and my forms are broken again. :frowning:

Good afternoon, I logged in using github to
my up the page. I did all the procedures that were lost like putting a root folder named index.html. Even so it continues to fail, I have no idea what to do. I would like a solution to my problem.

URL: https://princesinhadosquindins.netlify.app/
Dominio: princesinhadosquindins.netlify.app

root folder or root file, @igorgeneral?

The build settings need to point to a correctly named index.html file.

the folder can have a different name (no dots, special characters or spaces please) as long as the path you are using to point to it is correct in your build settings. The name of the index.html is not flexible. it must be called index.html (not InDeX.html or index.htm)

staging.sixtomidnight.productions/index.html exists and shows the form but I get the 404 page when sending. Please let me know if there is any additional info I can provide.

hey there, that is actually a different issue (when you see a 404 when submitting)

Give this guide a read through, it may help.