Page Not Found. index.html works fine locally but not on Netlify

I have started using Netlify in the last few months, couple of sites I set-up work wonderfully. One I set-up today is not working and no errors are generated in the deploy logs. the site is It’s a simple site with a one page form which uses obfuscated html code, the form is not used to collect any submission so I am not using the Netlify form tags. Could obfuscating code be an issue. I see no errors generated in the deploy logs. Thanks all for your help.

Hi there,

Did you see this guide yet? This is the best place to start for “Page Not Found” issues.

If you are still seeing issues after following the troubleshooting steps in this guide, please let us know!

Oh, and i also edited your username to something that doesn’t contain the word support just so there aren’t any misconceptions :wink:

1 Like

Thanks perry, first for your super prompt response, awesome :smiley:
The screenshot was helpful and I was able to download the file, didn’t realize that functionality was out there
I see now what the issue was; I was using index.shtml I renamed the file to .html and I am online :sunglasses:

Thanks for changing the username, :baby: newbie at this and the name came through automatically from email address

I am so impressed by both the Netlify service and support! Thanks all for your help.

1 Like

Hi Perry,

I have done the steps above and my deploy folder does contain an index.html file.

I have tried deploying it from my Github Master Branch:

I have also tried deploying it manually.

I am not sure how to go ahead.

Hey @TravisFriday, it looks like for, your publish directory is set to build/ here:

But in your repo, the index.html is in public/. Do you want to try setting your publish directory to public/ and see if that fixes things for you?

You can read more about build settings here:

Let us know how it goes and if you have any other questions!