Subdomain redirection

Hi,

We set-up our dns settings to redirect to the netlify site, but the redirection is not happening.

We verified the changes here:
https://dns.google.com/query?name=opencerts.sp.edu.sg

Netlify site: https://sp-indt-opencert.netlify.com
May I know if we missed out anything.

DNS looks fine for that hostname.

However, you have not configured us to actually SERVE that hostname, here: https://app.netlify.com/sites/sp-indt-opencert/settings/domain#custom-domains

All names you want to serve for a site MUST be shown in its domain settings page. The CNAME tells browsers where to find us; the config in our UI tells us what to serve to those browsers. If we aren’t configured, we’ll serve only the “Not Found” page you see, since we can’t tell which of our 10 million sites we should serve.

1 Like

I would always come to this step and get stuck, cause when I try to add a custom domain(blog.mysite.com) to https://app.netlify.com/sites/just-mysite/settings/domain#custom-domains, it would ask me if mysite.com is owned by me or not. From this prompt I would assume that it will redirect mysite.com to the Netlify Subdomain and not blog.mysite.com, so I would stopped at this step and looked for other solutions.

I don’t know if my reply improves the conversation or not. But, I think you should put a suggestion or something to clarify the misunderstanding I had.

Thanks for the feedback. Could you clarify a bit what exactly you expect? Not quite understanding from your description. I’m looking for something like:

  1. I enter custom domain blog.mysite.com in the netlify domain settings
  2. during that process netlify asks me if I own the domain
  3. I say yes, and <what do you do here?>

Does netlify manage your DNS or not? The changes we’d make differ in both cases - if we don’t own it, we’d never be able to make a new record. If we do manage it, we should make the record you’re expecting, and it should work, so we’d want to get a bug filed.

Thanks in advance for helping me get things improved for us :slight_smile: