Custom subdomain DNS setting not working


I am having trouble configuring the DNS registries for the website The domain is hosted by Aruba (an italian DNS provider), I have bought a third level domain from them,, which has a separate DNS console from the domain I have tried many combinations of DNS settings for, including, A records pointing to your balancer and CNAME records binding “www” and/or “blog” to “”.

I have also tried to set “blog CNAME” in the DNS console of the domain as this page suggests doing, with no positive results.

Woud it be possible for you to diagnose the current settings and tell me what’s wrong?


Also, on a different netlify project I have 3 custom domains, two of which are related to the custom domain ( that point to the netlify site. One is the primary domain (, the other ( “Redirects automatically to primary domain”. I would like to create the same setup for my site, but I cannot set the “Redirects automatically to primary domain” on any domain, I can only create domani aliases. I guess there Netlify is simply stating that the DNS settings on my DNS console “redirect automatically to primary domain”?

Thanks a lot guys!

The CNAME technique should work if you have this same FQDN set up in your Netlify DNS with the same FQDN as the primary domain. I have a couple of sites that are “connected” this way and it works perfectly.

Thanks for your reply! I don’t use Netlify DNS though, I use Aruba.

So if I applied the mentioned technique to Aruba basically it should be: CNAME
Should I place in the FQDN in the registry? Probably not what you are saying though…

Anyways this part is so confusing because the Netlify docs for subdomains say that I should place blog in the DNS configuration of the apex domain (which I did and does not work) but when I purchased the subdomain from Aruba they created a separate DNS panel for me, so intuitively I would say I should add configuration to the subdomain, not the apex domain.

Yes, but you still have to set your custom subdomain in the Netlify DNS section so they know to point requests to your files.

I managed to solve the issue in a different way :slight_smile:

Anyways thanks a lot gregraven!

1 Like