SSL Doesn't install

When I try to add an SSL certificate to my domain they give me the following error.

‘We could not provision a Let’s Encrypt certificate for your custom domain.’

My DNS settings are ok (I’ve got the NetflyDNS badge near my custom domains)

Could you help me?

Is there any error/warning in the SSL/TLS certificate section?
You might just need to wait a bit longer.

I agree. Give it a few hours, if still no change, please let us know the domain this is regarding.

Here my domains

Here my SSL/TSL certificate section

When i click on ‘Verify DNS Configuration’

Hi, @andreacanton. I see the Netlify DNS configuration here:

However, our DNS servers are not the ones being used by this domain:

$ whois | grep -i "name server"
   Name Server: NS1.TH.SEEWEB.IT
   Name Server: NS2.TH.SEEWEB.IT
Name Server: NS1.TH.SEEWEB.IT
Name Server: NS2.TH.SEEWEB.IT

There are two options:

  • delete the Netlify DNS configuration and use the external DNS instructions
  • change the name servers at the domain registrar to the ones listed in the Netlify DNS configuration above

​Please let us know if there are questions about either solution.

Hi! I have the exact same issue… Am using an external DNS provider for The A-record configuration worked fine, as well as DNS verification, but i get the same error as Andrea when i click “provide certificate”. Thanks for any thoughts and ideas, as the site currently is not secure and i think it also stops the forms from functioning properly. Best, Rosanne

Nevermind! Issue seems to be resolved… It just took more time than i thought :slight_smile: