Site cannot be reached after delegating the domain to Netlify DNS

Hello everyone,
I’m facing some trouble delegating my custom domain to use the netlify DNS for a static site. The site works on the netlify domain which is listed below but does not work with the custom domain.

Netlify app:
Custom Domain:, getting DNS_PROBE_FINISHED_NXDOMAIN.

I’ve waited for more than 24 hours, tried reseting my broswer’s cache, resetting my OS cache, tried it on my mobile network but still the site cannot be reached and I am getting the above error on the webpage.

Here are the logs from the dig and whois commands on the troubleshooting guide.

➜  ~ dig NS +trace | tail -n 6		3600	IN	NS		3600	IN	NS		3600	IN	NS		3600	IN	NS
;; Received 130 bytes from in 25 ms
➜  ~ whois | grep -i "name server"                   
Name Server:
Name Server:
Name Server:
Name Server:
Name Server:
Name Server:
Name Server:
Name Server:

From the above logs, it looks like the DNS delegation was successful. What am I missing ? and what other troubleshooting steps I can take to resolve this?

I appreciate the help. Thank you.

Have you assigned to a production site yet @sahil97?

Further reading

Yes, I did add that to the production site. Seems like I just had to wait. It started working last night.
The redirection works now, but shows as not secured and that the cerificate is not valid.
On the ‘Domain Management’ page it still shows as 'Awaiting External DNS` in front of the external domain and thus I cannot add the SSL/TLS certificate. It has been more than 48 hours as of now.

I only see AAAA (IPv6) records for and no A (IPv4)

Assuming you have NETLIFY and NETLIFYv6 type records for then everything is correct.

In either case, I’ll have to leave this in the hands of Netlify support.

Thank you for taking the time to look into this.
Is there a way to add the A records ?
I deleted all the DNS records from the custom domain provider(I moved the mail records first to netlify) and the external domain now only has name servers pointing to netlify.
Is there any other steps I should/can take ?

You could try the DIY options from @luke in the following post as I believe your issue is the same.

1 Like

Hi, @sahil97. Or you can wait for me to make the fix. :slight_smile:

It should be working now but if not, please let us know.

1 Like

Awesome. The site is working now with the SSL updated.
Thank you @luke and @dig for the help.