Delegating Custom Domain To Netlify Not Working


Just recently moved to Netlify yesterday and have tried to delegate my custom external domain (from Greengeeks) to Netlify, but it seems to still not be working despite waiting for the 24 hours propagation. I have done the following:

What I’ve Done:

  • Delegate my domain to Netlify, as per this article. I’ve pointed the nameserver details on Greengeeks to the ones listed on Netlify.
  • Wait 24 hours
  • Troubleshoot the DNS issues with dig, as per this article. The status result I got was NOERROR, which confuses me because I’m still not able to get it working in the browser.

Relevant Info:

  • Netlify site name: [REMOVED because solved]
  • Domain name: [REMOVED because solved]


On Greengeeks:
[REMOVED because solved]

Not sure if I’m doing something wrong/missed something. Going to my domain name on the browser still leads me to a broken page, saying that the “…server IP address could not be found”. Would appreciate any help I can get!

Thank you!

@purple-lemon Your site loads for me in Southern California, so you might be seeing a local caching issue. Try visiting your site in a new private / incognito window, or use something like GTMetrix to verify that it’s loading.

works for me too, @purple-lemon!

Weird. After trying:

  • On 3 different browsers (Chrome, Mozilla, Safari)
  • On 2 different devices (Laptop + mobile phone)
  • Troubleshooting with my ISP

It seems that it was my own WiFi network settings that was preventing me from getting to the website — accessing my website using mobile data worked whereas being on my WiFi did not work. My DNS server seemed to not play nicely with the new Netlify hosting. Changing the DNS server to seems to have fixed this issue.

Screenshot for future reference if anyone runs into this issue:

Thank you @gregraven and @perry for your help!

1 Like