I have a domain registered with AWS Route 53 and I’m trying to use Netlify DNS but I keep getting DNS_PROBE_FINISHED_NXDOMAIN even after waiting more than 24 hours.

I have tried setting my domain DNS to Netlify’s DNS and after it didn’t work I tried adding DNS and IP address

but I can’t seem to find the problem.
My netlify’s instance name is

Cheers and thank you!

Hi, @Jesusz0r. I’m showing this domain is currently configured to use Route 53, not Netlify DNS.

There are two commands/tools which I recommend for troubleshooting DNS issues: dig and whois.

First, there is the WHOIS data filtered for string “name server” (case-insensitive):

$ whois | grep -i "name server"
   Name Server: NS-1251.AWSDNS-28.ORG
   Name Server: NS-1873.AWSDNS-42.CO.UK
   Name Server: NS-632.AWSDNS-15.NET
   Name Server: NS-67.AWSDNS-08.COM
Name Server:
Name Server:
Name Server:
Name Server:

This can be confirmed with dig also:

$ dig SOA +trace | tail -n 12	172800	IN	NS	172800	IN	NS	172800	IN	NS	172800	IN	NS 86400 IN NSEC3 1 1 0 - CK0Q1GIN43N1ARRC9OSM6QPQR81H5M9A  NS SOA RRSIG DNSKEY NSEC3PARAM 86400 IN RRSIG NSEC3 8 2 86400 20191217055123 20191210044123 12163 com. IFjYHBv2IJZ9OhwwsNw1ecOOkp7pleWQo8Cto/V2ya2VLktyjgKgGgcw XAUk9RTgyWOzjdzUGl3ApAwFJ6Cerma2Hlcukq0ec2n97IBlWwi9WqKU VZ1dkTYrriu/1JOnm1gpLFVs0JrlYQjfnSHKxbVIEv6DESAOcn8dNdLJ oKvALhpyjIQAjX0I8W3AeKpRTZVKHn45DkBi/V5znpUDwg== 86400 IN NSEC3 1 1 0 - BJ8K7B695VA3LU4BTUEAL2D6935GA781  NS DS RRSIG 86400 IN RRSIG NSEC3 8 2 86400 20191215063249 20191208052249 12163 com. RUP3POBAOBzlWTvJqwA7CapQ2zXbmXp5EopOQ+CkkY03USgjfU2pD/Oj 1iTI2vVmb8FhTYXN/Ka7WUi2XpkhgkbnmnaEVVO7c2TEXftVoB/vn/P5 Y7+EJPA5J4ybw9xxiJK7D2130JaDCJ8zGhJQ2c/JjCZ6H2Gx9DsFmvtD 2nAbVsiwNJCcYk/qyrFF/5+IOa7iez8bAuQzHNlnpzddQQ==
;; Received 746 bytes from in 56 ms

;; Received 34 bytes from in 12 ms

Note, in the request above, I’m asking for the start of authority (SOA) record. The name servers are reported as AWS Route 53 name servers but, when dig queries one of those name servers, it doesn’t respond with an answer for the SOA record.

I believe the following instructions explain how to change a domain’s name servers are Route 53:

Note, using Netlify DNS isn’t required to connect a domain name with a Netlify site (although it does automate certain features of our service, like SSL certificates for branch subdomains).

You can use AWS Route 53 for DNS and still connect the domain to Netlify using these instructions:

1 Like

Hey guys. I found the solution.

It turns out that you don’t have to change any record in your hosted zone. You need to go to:

Route 53 -> In the left Panel choose Registered Domains -> Select the domain you wish to change the DNS -> In the top menu choose Manage DNS -> Change all the records to Netlify DNS records.

1 Like

Thanks for sharing how you solved it, @Jesusz0r.

Could you elaborate? I’m struggling with the same integration (Amazon Route 53 registered domain -> Netlify nameservers). Here’s what I’ve done and my domain still isn’t going through Netlify:

  • Added all MX, TXT, CNAME record set types in Netlify (i.e. add to Netlify, map back to AWS for email etc)
  • Update AWS NS record with Netlify’s name servers
  • (SOA??) Update AWS SOA record: use one of the Netlify name servers for authority-domain but hostmaster-email-address is still AWS. I haven’t seen any documentation from Netlify on whether to update this record but I feel like it needs to change.

Thanks for sharing!

Yeah, sure.

You don’t have to change any thing from the hosted zone.
All you have to do is go to Route 53 -> Registered Domains -> Find the domain you want to configure -> Manage DNS (As shown in the image) and then, all to the right you have an option called “Add or edit name servers”. Click ther and replace all the values with your Netlify DNS values and then wait a little bit until the changes are applied


Somehow that clicked with me, thanks for patiently explaining again! I have multiple domains in Route 53 so my steps were:
Route 53 > Registered Domains > (click my domain) > In “Name servers” section, click “Add or edit name servers”. This popped open a modal and I added Netlify’s four name servers and removed all of AWS’s. Tested and it works!

I was getting stuck in a loop because clicking the Manage Domain button directed me to Hosted Zones and this is where I was stuck thinking I needed to update the NS record (dunno, I’d already done this so maybe it was 2/2?).

Thanks again, really appreciate it!

1 Like