Problem Adding Custom Domain - Another site is already using

hi there,
could you try again, and if it does not work to add the domain, could you please grab a screenshot and comment here with that screenshot? thanks!

Here is a screenshot of the Netlify configuration page and the AWS Route53 configuration page. Please tell me how to reset it.

hi there, have you tried clicking “add domain”? what happens? thanks.

Hi there I’m having the same issue with domain
Telling me that custom_domain is owned by another account.

Can you help me please!

hi there, did you make a verification record as per this guide?

Yes I asked the other account (collaborator) to delete the domain and he did. He also deleted the app just to be sure and I still have the error custom_domain is owned by another account.

Site name: geniuzedu

Thanks for the quick reply!!

I’ve done all the steps:

  1. asking collaborator to remove de domain
  2. Add TXT record

Can you help me with this?

Best regards!

Hey @ajunior,

The domain has been removed from the other account.

Hey there, I am facing the same issue. please check my this post.

verify my domain ownership

This has been solved there.

It seems that it was a misunderstanding. Now it’s settled. Thank you.

1 Like

Okey, yes I just tested it and it’s working fine.
Big thank you!

1 Like

I have same problem that another site is already using this domain. I added TXT record to verify domain ownership. Please help remove it from another account.

Please remove

Hi @ecorfy,

The domain has been removed from the other site.


It is solved yesterday, but not working again. What happened? Pls help asap

Please ignore. Now it is working again after readding domain in control panel.

I have the same problem with my domain: I’ve added TXT record with the ticket number I’ve received. Can you please look into this?

hi there, we have freed up the domain for your use!