Possibly more DNS issues


So today I’ve been unable to access my domain via the registered name, but if I paste in the sleepy url above I can reach it.
When I DiG from my local machine, my domain, I get an A record that’s different from what a 3rd party like MXToolbox says for a DNS Lookup. I am still using Netlify’s DNS and I’ve not added to modified any records.

DNS Checks still show the backend provider is Digital Ocean like it did last week.

Also verified namecheap is still pointed at Netlify’s DNS servers.

@invalid.path At some point, you’re going to have to share your custom domain name for anyone else to help you.

Oh… well crap lol. I wasn’t sure if that was ok here or not: BenHart.dev is my domain.


I’m able to reach your site via your custom domain name, and the apex domain redirects to the www subdomain as it should.

AFAIK, when you have your DNS with Netlify, reports on the A record for your custom domain can change as needed by the Netlify system.

If you still cannot reach your site via your custom domain, you might try clearing your local/browser DNS cache, and/or try visiting in a new private/incognito browser window.

1 Like

So I’ve fought DNS issues many, many times over the years. But I have never come across something like this before. I’m getting a revolving cycle of various addresses DiG’ing or using nslookup from inside my network.
Namecheap is pointing to Netlify for DNS. Netlify is showing as authoritative however online-based domain dns checks return different IP addresses than I do internally. I mean I’m talking within 2 seconds from each query teh results being different.

I do not use proxies, I turned off, private browser tabs, cleared cache… and this happen on my machine as well as 2 Windows servers that are my domain controllers. Locally, I even tried setting my pri dns to Netlify’s primary address…still no dice.

I legit do not know what to check now…

You site still loads for me, and with good scores from GTMetrix and Pingdom. Good report from DNS Health, too.

Oddly, TestMySite never gives a score, which I’ve only ever seen on a Frontity site delivered by Vercel – a completely different beast than what you have.

If you have a smart phone you could try visiting your site over LTE, which should bypass any home/office network weirdness.

Then, if you have already tried deleting and re-adding this custom domain to your site, it looks as though someone at Netlify is going to have to check the see if there is anything odd going on.

Hi! We do have many CDN nodes so it is expected and intentional that a single domain name resolves to multiple IP address. You can even see this with www.netlify.com as it is hosted on our service:

$ dig A www.netlify.com  +noall +answer

; <<>> DiG 9.10.6 <<>> A www.netlify.com +noall +answer
;; global options: +cmd
$ dig A www.netlify.com  +noall +answer

; <<>> DiG 9.10.6 <<>> A www.netlify.com +noall +answer
;; global options: +cmd
www.netlify.com.	19	IN	A
$ dig A www.netlify.com  +noall +answer

; <<>> DiG 9.10.6 <<>> A www.netlify.com +noall +answer
;; global options: +cmd
www.netlify.com.	19	IN	A

Three request in a short time and three different IP addresses returned. Again, this is intentional and correct behavior.

I checked the site-name.netlify.app version of the site and there is no site named sleepy-mclean-09a3df.netlify.app at this time.

I do show https://benhart.dev/ working but that domain name isn’t connected to the site name above, it is connected to https://benhartdev.netlify.app/. Both sites do show the same content when test.

If there are other questions about this, @invalid.path, please let us know.

Thanks Luke, No I discovered that you could change the site.netlify.app link so I did to something I could remember more easily. I still have the issue here at work and have not discovered the ‘why’… but everywhere else she’s good captain!

No qualms, @invalid.path. Your config is very straight-forward from our point-of-view so there’s no reason why it should be erroneous.

I can only presume that there’s some funky routing and/or proxying when you’re on your corporate network.