Only OpenDNS have records about my domain

I have added my domain to the netlify DNS, and then connected it to the netlify site.
Usually it will start working almost immediately, since I use google DNS on my machine, but not this time.
I have checked the site with keycdn dns tool, and here are the results:

only some of the DNS providers have the records for the domain, but not the others.
I have waited I think 48 hours, and cleared the DNS cache couple of time, but the result still the same.

Can you please assist me with this, I haven’t seen this issue before.

As I can see from my other tests, Google DNS and other providers can’t fetch the records because the DNSSEC verification failed. And even after I requested my domain provider to disable it, it’s still the same. So I have no other options rather then stick with their inhouse DNS management, and use the CNAME records. That’s sad as fck.

Hi, @brokeyourbike. You are correct that Netlify DNS doesn’t support DNSSEC at this time.

We do have an open feature request for this and I’ve added this community topic to the list of +1s for the feature.

If/when DNSSEC is supported, we’ll update this community topic to let you know about it.

Also, thank you for sharing what you discovered with a follow-up here. This will hopefully help others searching for the same issue.

1 Like