New site is initially suspended

Hi Everyone :blush:

I am currently trying to deploy my first site (youthful-visvesvaraya-a4ff01) on Netlify from a GitHub repo. Currently that site has a “Suspended” status and I cannot find any information in the Docs or Community describing this status. Visting youthful-visvesvaraya-a4ff01.netlify.com displays This site is suspended.

The repo backing this site can be found at Galadirith/galadirith.github.io. To be transparent about what actions I have already taken, I had planned to add a custom domain brothers.page to the site. After creating the site it started with a suspended status. I still continued to try to add the custom domain which did not change the suspended status. I have now removed all the custom domain settings that didn’t work so the site is in the simplest possible state to try an diagnose the suspended issue. The repo was also originally private when I create the site on Netlify, but is now public.

Automatic build and deploy when I commit to the repo also does not work, although I’m currently working on the assumption that this is related to the suspended site status.

Thank you so much for reading even if you can’t help me solve this issue :blush:

I created a new site from the same repo and everything worked as expected with no site suspension. While I don’t know why my first site was suspended my issues have now been resolved.

Hi, @Galadirith. I also don’t know why that wasn’t working.

How did that site get deployed? What team was the site under? Was it deployed using Netlify Drop?

1 Like

Hi @luke thanks so much for looking at my issue.

I deployed the site using New site from Git, selecting GitHub and then selecting my (then) private repo Galadirith/galadirith.github.io. It was under my single user team Edward Fauchon’s team (galadirith) on a Starter plan. It wasn’t deployed using Netlify Drop.

I’ve made the repo public again in case it’s useful for diagnosis. The original commit that the site was deployed from was cf04bb7 and I made a couple of commits, 84897f6, ce27f77, to try to resolve the site suspension before opening this thread.

I tried again this morning to create a new site from my private repo before making it public and it also worked without issue https://stupefied-williams-9d9707.netlify.com/ like my second attempt.

I will delete https://stupefied-williams-9d9707.netlify.com/ and make Galadirith/galadirith.github.io private again on Friday afternoon.

hmm, very strange. Thanks for the extra information, @Galadirith! Will you get in touch again if you have more problems, please? Seems like this was something we’re not going to be able to reproduce, but we’ll definitely look into it if it happens again.

1 Like

Thanks @perry I will report if anything happens again. You made the process really quite simple to deploy a site from GitHub :blush: Even though I’m quite certain I recorded the steps I took, maybe I missed something.

In any case everything is working seamless for me now, thanks @luke and @perry I really appreciate the care :+1:

1 Like

I also got this problem. The site is clever-brattain-0968b3 and the repo is https://github.com/squaresmile/apps. I tried creating a new site nifty-bell-9d7f4d like Galadirith but the new site also has “Site is suspended for non payment” status. I’m not quite sure what payment is needed here? Do I need to add billing info even for the starter plan?

I created the sites using the new site from git button, picked the repo, set the build command to cd packages/db && npm install && npm run build, the build folder to build and clicked “Deploy”. The sites became suspended when the build finished.

image

hi there @squaresmile, I am checking in on this, stay tuned.

Hi again @squaresmile! I took a look at that content and there is no content. We don’t intend to host sites that are just a redirect to another site. Please add more content if you want us to host your web properties; if you don’t, our systems will continue to disable those sites as that is not the kind of content we are willing to host.

I see. The site is a viewer for data returned by my API so there’s no “content” but it probably isn’t “a redirect”. It’s unlikely the site model will change so I guess netlify won’t work then. Here’s the site where it’s currently hosted: https://apps.atlasacademy.io/db/#/.

Thanks for your help.

Here’s the entirety of the html you deployed:

<html>
  <head>
    <meta http-equiv="refresh" content="0;url=https://atlasacademy.io/apps/" />
    <title>Apps - Atlas Academy</title>
  </head>
 <body></body>
</html>

I’m saying you need more content to host here. That doesn’t actually do anything except redirect to another site, as you can see :slight_smile:

Ah, I see. I need to fix my build process then. Thanks

Is there a way to remove or edit the suspended sites? I don’t think I can click on them.

I’ll be happy to remove them for you once you are ready, just tell me a list.

Can you delete these sites:

  • nifty-bell-9d7f4d
  • clever-brattain-0968b3

Thanks a lot.

Also, I fixed the build folder and the site is working now :slight_smile:

sure thing, tis done!

Hi @fool — I think I’m having a similar issue with a site I’m trying to deploy. For context, it’s a documentation site with folders organized by version number. The main index.html just redirects to the latest version (so SITE_URL/index.html → SITE_URL/0.5.19/index.html, for example). But I think I’m getting the “Site Suspended” issue because the main file is just a redirect. Is there a way to work around this?

Seems likely this is the cause.

Took a quick look at your site layout and that’s a pretty inefficient way to handle that redirect. Could you try deploying no index.html, or one with more contents, and instead using our redirects (cf Redirects and rewrites | Netlify Docs) to handle the redirect? It will be way faster than doing it client side, for repeated visitors and new ones both :slight_smile:

something like this should work as a redirect rule:

/ /0.5.19/ 302!

Should be all it takes - and that shouldn’t be a problem for our automated handling to trip over!

That seemed to work! Thanks so much for the pointer. I do have a few sites that are locked in that suspended site now, however, and I’m not sure how to remove them. Could you do that? The sites are:

  • hungry-jepsen-d0b5e5
  • gracious-sammet-898294
  • lucid-davinci-2407e2
  • flocc-docs

Sure thing, just got them re-enabled for you. I can’t promise they won’t get re-disabled with that content in place though.