Home
Support Forums

Netlify stopped fetching data from a particular content folder

I only noticed this happen today. I tried gatsby-clean, build and serve and don’t have the issue locally. I did a git pull and git push and can see the content unchanged since a week ago. Repository is here. Only the content in /schedule stopped being found by netlify.

I checked the graphQL name to ensure there wasn’t any duplicate queries too.

The build and deployment worked fine and as I said, locally I don’t have an issue. I also tried ‘Clear cache and deploy site’.

I checked the /admin site and can see the content and the content is published.

The site is here: https://tirol-dragon.netlify.app/. I’ve added source maps for ease of debugging.

Thanks for the help!

hi there, can you provide a bit more info on which content isn’t getting loaded?

Hi Perry,
the info under /content/schedule isn’t being loaded by the schedules.js component:

import React from "react"

import { useStaticQuery, graphql } from "gatsby"

import ScheduleDay from "./schedule-day"

export default function () {

    const data = useStaticQuery(

        graphql`

        query ScheduleQuery {

            allFile(filter: {relativePath: {glob: "schedule/*"}}) {

              group(field: childMarkdownRemark___frontmatter___day) {

                edges {

                node {

                  childMarkdownRemark {

                    frontmatter {

                      endTime

                      startTime

                      day

                      classLabel

                    }

                  }

                }

              }

              }

            }

          }

    `)

    return (

        <section id="schedule">

            <div className="section-head">

                <h2>Schedule</h2>

                <p>Class times are as follows</p>

            </div>

            <div className="row">

                <div className="schedule-tables bgrid-fifths s-bgrid-halves">

                    {data.allFile.group.map(({ edges }, index) => (

                        <ScheduleDay edges={edges}></ScheduleDay>

                    ))}

                </div>

            </div>

        </section>

    )

}

I also tried deleting the /schedules folder, push/commit and recreate anew and commit/push in case there was a cache issue but again, I got the expected results locally but not when I deploy to netlify

hey there, thanks for your patience. Have you made any progress, or is this still a problem?

Hi Perry,
in the end I renamed the path from /schedule to /timetable and renamed the query which meant it had to generate a new query and cache. That did the trick.
Cheers
Rory

1 Like

thanks for letting us know - glad you figured out a solution.