Netlify not recognising any branches to deploy


I’m trying to create a blog using my html site, eleventy and Netlify, but am having issues deploying my site with Netlify - see image for all relevant information (cam only post one but perhaps I can reply with more images.)

Everything is working as intended when hosted locally, but for some reason Netlify is returning an error saying that no branches can be found when I go to deploy the site.

I’m new to coding in general, but my GitHub desktop app says my current branch is “main”, which I understand is interchangeable with “master”.

I’ve seen tutorials online where people are using the git commands to publish their branches, but I used the GitHub desktop app instead - not sure if that was necessarily the right thing to do, but I first committed my site files to “main” and then published the main to GitHub with no problems.

Any help would be greatly appreciated.

What I’ve tried so far:

  • Reconnecting my GitHub acc to Netlify (no success)
  • Checking the repository in Netlify with the correct one I’m using (appears to be the same)

Thanks in advance,

Image for site info:

This is not true. main and master are two different branches.

Based on your second screenshot, I can clearly see, it says your branch hasn’t been published to GitHub. You need to publish the branch.


Okay apologies - I read online that the “master” branch is just the predecessor to the “main branch” but they mean the same thing.

I have since solved the problem by using the terminal to add, commit and then push the content to the main origin.

I originally published using the GitHub desktop app, which then blurred out the button so I assumed it had already worked (I couldn’t push the button to publish anymore).

Not sure if any admin members can list this as “solved” or something, but that seems sensible for anyone else who gets the problem.