Netlify keeping old dns records

My friend and I were using netlify functions for our project at https// and with our custom domain but then we changed to a different method, however, when entering our site it keeps redirecting us to the functions folder which doesn’t exist anymore and it hasn’t for a few days now. We were wondering if netlify has a cached version of the site maybe because we have deleted our protect and recreated it in order to have our custom domain point to a different netlify subdomain but it doesn’t work and the dns records remain pointing to even after having deleted the entire project and opened it with a different name. We’d very much appreciate if you could delete the cache on your side for us. Thanks in advance

Just removed the old DNS Zone from our servers; deleting an account does not do this, as you discovered. Don’t delete accounts in the future if you want to use our service again, please - that is intended to be “goodbye”, not “reset”. Let me know in case you still can’t get things working as you’d like!

Thanks a lot I understand that now and I am not being redirected to the old domain and path anymore, however, I keep getting an error, I loaded my website in my phone once and it worked and then I kept that tab open then tried loading it again in another tab and I get this error sent an invalid response ERR_SSL_PROTOCOL_ERROR when I refresh the first tab it does work though. Also, when trying to open it in my pc web browser I get sent to my domain’s provider default page. I have no idea what is the problem at this point, I checked if maybe there were too many ssl certificates issued to the domain but there is only two so that shouldn’t be a problem. Any ideas?

Would you please let us know the day/time/timezone of the ERR_SSL_PROTOCOL_ERROR and what IP address was the one to respond?

If we returned an invalid SSL certificate this will help track down the issue.