Netlify Identity: failed to load settings

Screen Shot 2020-03-11 at 10.59.32 AM

Unfortunately I see this message in the log in popup: “Failed to load settings from”.

It looks something simple but I couldn’t find anything online.

thanks in advance for your help!

Fabio Vedovelli

Hi, welcome!

There’s a couple of things you can do. First, check if you have Netlify Identity enabled in your dashboard settings (Settings > Identity). If you’re using Netlify CMS with git-gateway as a backend you also will need to enable Git Gateway (Settings > Identity > Git Gateway (last entry) > Activate). You can learn all about the Identity service here:

If this is happening on localhost while trying to reach the Netlify CMS’s admin panel and you do have Identity enabled, you might have entered the wrong URL. Try clearing your cache to enter the correct URL. This doesn’t seem to be the case, but thought I’d mention it just in case.

1 Like

Thanks Tom for your quick reply!

  • I have Identity enabled for that site;
  • I can access and see the message {“code”:401,“msg”:“This endpoint requires a Bearer token”};
  • I am not using Netlify CMS but enabled Git Gateway anyway and it doesn’t solve the issue.

Lastly I am running a Nuxt.js project with SSR. Not sure if that would play a factor here.

Best regards,


That 401 message is default behavior when you navigate to the URL. Not sure what is going on though. Can you share the code you use to initialize the identity widget?

You could try to delete the Idenity instance and re-enable, that sometimes helps. You could also try to create a new site with the same repo to test if that works.

Yeah sure, I understand that. I’ve mentioned just to let you know the service is enabled for that website.

You can see my super simple implementation here:

Screen Shot 2020-03-11 at 12.07.08 PM

Nothing fancy, I just copied and pasted an example!

Well, nevermind. I created a fresh Vue project and the integration worked first attempt. It might be something with Nuxt. Maybe start the widget in a plugin will fix it.

Thanks again for your help!! Have a great day!

1 Like

I just tested the code on a blank site and it seems to work just fine. Maybe testing the same repo on a new site or delete the identity instance and try again!


I’m currently in localhost using the Netlify dev server. Does my site need to be “deployed” in order for identity to work in localhost? I am also getting the error message (using the react templates) "Failed to load settings from Any help is appreciated, thanks for your time.

Hey @audetcameron,
I believe that you will have to deploy a site on Netilfy and enable Netlify Identity in your site dashboard, but after that you should be able to experiment with that site locally without pushing changes. To get rid of that error, have you tried the steps here?

Let us know if you have and we’ll keep digging!

Thank you for the response. I was successful in getting Identity to work. After publishing the site as a placeholder the identity service started to work. I also noticed (because I’m using react) that I was viewing my localhost on the wrong port. As soon as I switched over to the proper port (using Netlify Dev) functions started to work as well. Amazing service, thanks again