Netlify drop with supervised user on ChromeOS

I’m trying to teach my kids how to program HTML and they’re writing a website using a chromebook and their family link supervised accounts. Supervised accounts require that a parent approves each domain they can access.

When trying to upload their site using drop the site has an error. I don’t have access to dev tools from a supervised user so it is difficult for me to troubleshoot. I tried uploading the site from my computer and watching the domains accessed (eg and and then allowing those domains for their account but I still get an error. Usually if they go to a website directly they can ask for permission to the domain but sites/domains used on pages without explicitly typing them into the address bar are treated differently.

Here’s the error I see now after allowing domains I was able to find from my computer.

Is there a documented list of domains drop uses to upload a website zip? I haven’t found much documentation on what drop uses and it would be great to get this working for them.

Are there other things I need to consider when using a chromebook with drop?

Thank you

Hi, @rothgar, we have had numerous reports that Netlify Drop doesn’t work on ChromeOS due to restrictions of the operating system itself - not Netlify.

That restriction being that there is no way to drag and drop local folders into the browser. Have you found a way to do so? Are you able to drag and drop folders into other sites besides Netlify?

I can’t drag and drop folders into Chrome on any machine but zipping the folder first works on Chrome OS and my other computers.

I was able to deploy the demo site by uploading the zip from Chrome OS as my user and not my son’s.

Thanks for sharing how you got this working! Will be very helpful for others trying to build with Netlify on Chrome OS. And very best of luck and <marquee> tags to the new coders :hammer_and_wrench:

The zip file work from my user but I’d still like to know a list of domains to allow from my son’s account so he can delpoy the site too. Is that available somewhere in docs?

Ah, totally misunderstood that this was still unresolved!

That information is not listed in our docs. Do you have unblocked? That’s definitely the main one.

I unblocked on his account and tried uploading the zip again and I get the same error. is also unblocked.

Hi, can you also allow We use this for the deploy logs. That’s the only other domain that I know we use during the deploy. Let me know how it goes.

I went ahead and worked around this issue by having my son save his files to his google drive via the files app. I shared the folder with my account and then published the files via a gitlab repo push -> netlify.

It may not be a fix for other people that don’t have this option, but it worked in my case and makes it so my son doesn’t have to think about the publishing side of things.

thanks for sharing your solution - this isn’t something that has come up before, and we’re glad to know of a workaround, and if this issue comes up again, we’ll try and think of a better way to help.