Netlify Create: Not editable / Old site (Stackbit) / Root cause?

ISSUE: Cannot edit page
ISSUE 2: Receive ORANGE warning “You haven’t configured how content models map to page URLs”.

Why helpless: worked a few months ago for content changes. No changes since then. Backend change @netlify suspected.

Attempted Mitigtation:
Read Structured content | Netlify Docs , Content Modeling | Netlify Create Docs ,

Netlify site name: iaeste-hh-ee1a7.stackbit.app

  • Did you try Ask Netlify, our generative AI chatbot, before posting? It pulls info from Support Guides and recent solved forums posts.

Yes, I did. But it only yielded the info that I need to provide a content model in the stackbit.yaml

I did not need to do this before so i am stumped on WHY anything even happened.

Can someone shed some light?


Context: this is a low-maintenance static page that is miles away from what an SPA could be delivering. We need to make a small legally required change in the footer and the effort of rebuilding a whole darn content model from scratch is very daunting for unpaid volunteers.

I have mitigated this issue by editing the content source files in the repo directly.

I would still like to understand what happened between Feb 7 (our last edit) and today that the WYSIWYG editor doesn’t work anymore with the above error message.

What happened after you read that? Did you configure your site accordingly?

Can you provide more details on how you updated the repo directly? Followed the documentation to add and update a stackbit.config.ts file from the chatbot which did not fix the issue as well.

I did not understand what I should do. The page contains a lot of information - that doesn`t directly pertain to my case. There is literally no starting point.

Understanding -what happened - and what led to this change would be a starting point but there is no mention of that at all.

I made the edit in the github repo, specifically opening the file in edit mode on github.com and then pushing the changed file as a pulll request and then merging that opull request.

I am facing the same problem. Could you please share in details how you solve this problem