Netlify-cli deploy fail at "Waiting for deploy to go live"

Site name:
Netlify-cli version: 2.46.0 and tried with 2.50.0


We deploy with netlify-cli and since today, all deploys fail at “Waiting for deploy to go live” with this output :

“deploy”: {
“state”: “error”,
“name”: “pro-passculture-integration”,
“error_message”: “Deploy processing failed after 5 attempts”,

Error: Deploy 5ebxxxxxxxxxxxxxxxxxx had an error
at loadDeploy (/opt/circleci/.nvm/versions/node/v12.14.1/lib/node_modules/netlify-cli/node_modules/netlify/src/deploy/util.js:89:29)
at runMicrotasks ()
at async Timeout.check (/opt/circleci/.nvm/versions/node/v12.14.1/lib/node_modules/netlify-cli/node_modules/netlify/node_modules/p-wait-for/index.js:16:19)

The deploys are run with the following command :

netlify deploy -s “<NETLIFY_SITE_ID>” -a “<NETLIFY_TOKEN>” -d build/ --prod

We tried to extend the timeout, no difference.
We tried to deploy a preview version (which is working) and publish it from the web interface. But again it fails, telling us « Validation failed: Custom domain must be unique (

On May 7 at 3PM UTC +2, we have deployed without some problems. Do you have a idea why deploys fail ?


hi there, we just made some changes to how deploys/domains work, can you try again and let us know if you still see this issue?

Hi, It works!! Thank you!

Can you give more informations about this issue ?


glad its working! It was a temporary issue that was situation specific and has since been mitigated :+1: