Deploy failing at final stages

Hi, I’m troubleshooting a couple of issues with our Netlify deployments. This started after a deployment yesterday, and some users starting reporting seeing blank white screens for our site until a hard refresh. Sounded like a caching issue but I thought much of this was handled automatically - not sure why it would occur here.

I updated our headers in my netlify.toml, redeployed with the option to clear the cache and that successfully deployed (though not sure if it actually fixed my caching issue).

Since then I’ve tried several times with a followup deployment and the build process now errors out prior to the ‘prepared, ready’ state near the end.

8:10:37 AM: Starting to deploy site from 'public'
8:10:37 AM: Creating deploy tree asynchronously
8:10:38 AM: Creating deploy upload records
8:15:38 AM: Failing build: Failed to deploy site
8:15:38 AM: Failed during stage 'deploying site': Failed to execute deploy: Error: deploy timed out while waiting to enter states: prepared,ready
8:15:39 AM: Finished processing build request in 7m28.586069747s

I appreciate any help you can provide!

Yep i have the same issue, also it’s not picking new comits from GitHub

I have the same issue, stuck at uploading phase for project. Not picking up Github commits, retry deploy gets stuck.

2:32:52 PM: Starting to deploy site from ‘public’
2:32:52 PM: Creating deploy tree
2:32:52 PM: Creating deploy upload records
2:32:52 PM: 5 new files to upload
2:32:52 PM: 0 new functions to upload
2:33:04 PM: Finished processing build request in 34.504369422s

I noticed I had a new commit that took about 10 - 15 min to get picked up. It was definitely delayed.

I might be having a similar (but not same) issue?

Everything builds fine, then netlify deploy hangs on " Waiting for deploy to go live…".

I tried it with netlify cli 2.50 and 2.52.

sounds like same issue

Hi there, we were having some build delays on May 30th, I am wondering if that was when you were trying to deploy. More on that here:

Is deploying working for you now, or are you still having issues?

I was getting reports of this last week from a couple of people, but never able to reproduce myself (other than that screenshot above that was provided to me). One of the people reporting the issue says it seems to be resolved and he’s unable to reproduce it any longer.

Since it occurred prior to the build issues on Saturday, my guess is that this was outside of that.

hmm, noted. I’m glad its working now, we had some turbulence last week in a few places, its true.

Not trying to duck responsibility here one bit :duck: , but it is pretty hard (as in we can’t) trace back these kinds of problems without understanding how to reproduce them. If someone (you or anyone else) sees this happening and can link us to a failed deploy, we will try and debug / file issues as best we can!

Shoot sorry Perry, I was looking at the wrong post. I absolutely think you were right with this one. I was thinking this was another post I’ve got up here for a CDN caching issue.

Please disregard my earlier comment - this issue was probably caused by your build issues on the 30th as you mentioned.


1 Like

noted! thanks for clarifying. :+1: