Netlify can't see new branches/tags in github

In the past, the netlify site for MetalLB ( created a deploy per branch and tag in . I rely on this to link to old documentation from the main website.

However, with the recent release of MetalLB, Netlify did not deploy for the v0.9 branch, or any of the tags within (v0.9.0, v0.9.1, v0.9.2).

I tried to manually trigger a branch deploy by creating a build hook that points to v0.9.2, but the list of available branches in that UI does not list any v0.9 or v0.9.x branches, even though they exist in the upstream repository. I tried creating a trigger on v0.9.2 anyway, but the deploy fails with

At this point I’m at a loss. AFAICT the state in Github is correct, but Netlify is not picking up on that. What am I missing?

One possibly relevant item is that I moved the Github repo from my personal account into an org ( to I relinked github from the Netlify control panel when I did this, and Netlify didn’t complain, but I figured I’d mention it in case it’s relevant.

Hey @danderson, sorry to hear you’re running into this. One thing that may be happening is that the switch to a new repo may have automatically implemented monorepo support, something we rolled out in October 2019 that changed how base and publish directories work:

Looking at your netlify.toml on the v0.9 branch, we might be trying to publish website/website/public.

Could you try changing:
publish = "website/public"
publish = "/public"

I also see that in, you don’t have individual branch deploys set up. After editing your netlify.toml, could you try choosing the branch you want to deploy there?

Hopefully this helps, but, if not, come back so we can keep digging.