Home
Support Forums

Need Help Resetting Email Config for no-reply

Hi All,

Is there a way to return to the default no-reply@netlify.com configuration?

When I try to clear the fields or use default values the form refuses to accept missing fields, as it originates.

We have a major problem with new sign ups (registrations) because our configured no-reply is broken. We’ve been failing sign ups for ~36 hours. We really need help.

Thanks!

Hi @VaughnVernon

Is this related to your previous thread Configuring Custom no-reply email?

Yes, exactly. I have also sent the same to Support with little response.

Hi @VaughnVernon,

Sorry about the delay, this has now been reset.

Thank you so much, Hrishikesh!

Is there a way for me as an owner to reset to the default no-reply@netlify.com?

It seems like a really good idea to have a Reset button that both clears the settings and persists the change.

Also, is there better documentation on using a Google Workspace email account (alias) as a no-reply accounts? I can’t find much if any useful documentation on this topic (see links).

https://support.google.com/a/answer/176600

https://support.google.com/mail/answer/185833

Thanks in advance for the additional help.

Unfortunately, not at the moment.

I believe any valid SMTP configuration should work. Is that not the case?

No, hat is not the case.

Also our reset on Email configuration was just switched back to the broken state (previous problem). Could we please get the reset / clearing of our custom settings and revert to default settings until we have a working no-reply email?

Thanks!

It’s been reset again.

Thanks, Hrisikesh.

We have just succeeded in getting our GitHub OAuth working and now trying to get Google OAuth squared away.

But the no-reply@vlingo.io with our previous configuration never worked. New registrations were failing due to not receiving confirmation emails.

Someone in a thread somewhere (you, in the Support forum?) said that most of your customers use the default no-reply@netlify.com and suggested sticking with that. It seems strange to me to not have a rebranded email address that represents our company, and doesn’t disclose our cloud platform. Perhaps you could make it appear that the email is from a customer brand (don’t recall all the email on-behalf-of, etc., options) and make it appear that it is our email address and user logo. That would at least give us an easy way out and forget all the SMTP hassles.

Any insight on how to get our own no-reply working or enhanced default features you can provide would be greatly appreciated.

If you could setup a different website and setup SMTP credentials on that, we can see in our logs why it might be failing, or probably see what error we’re getting when trying to send emails from those credentials.

You could also try using a different SMTP in the mean time to see if it works to isolate this to maybe Google Workplace SMTP only?

I have set up a new site and created a completely new and non-aliased user. Please contact me on my direct email address for confidential information. Thanks.

Could you share the site name?

test-oauth-and-no-reply

Hi @VaughnVernon,

I checked that website, but sadly there’s nothing interesting in the logs. In the past, we got some text like:

error = "Error sending confirmation email: gomail: could not send email 1: 554 Transaction failed: Invalid domain name: '12313'."

OR

error = "Error sending invite email: gomail: could not send email 1: 554 Message rejected: Email address is not verified. The following identities failed the check in region US-EAST-1: email@domain.com"

That could help us troubleshoot. But i am not seeing that happening here.

Could you try to use the Netlify Identity Widget for the time being on this test website to see if that creates a difference (or at least show us some helpful logs like the ones above)? I don’t really think that should make a difference, but that’s the only area where I see your setup differs than the ones that showed such errors.

Thanks, Hrishikesh. It was late in the day Friday by the time this site was set up. We have not attempted any registration tests. You could register with some fake user and create logs yourself.

That’s what I’ve been doing and I’m not seeing any logs, which is something I wonder why.

I am seeing that the email failed to be sent (as that’s the error returned to the client-side), but there’s no separate error mentioning the cause.

Got it. The developer of these components has been alerted and should join in soon.

Hi @hrishikesh.
This the response from https://test-oauth-and-no-reply.netlify.app/.netlify/identity/signup

{
  "code": 500,
  "msg": "Error sending confirmation mail",
  "error_id": "01FMZ4SY30GECGJTM64CT7MR54"
}

The response don’t mention the error raison, just the error_id.

Yes, I’m aware of that and that’s the only line of information available in our logs as well.

I am just wondering why i’m not seeing any logs for the reason just like I saw them for other websites. These logs are not sent to the frontend and are visible only to us, but I’m simply unsure why there’s no trace of it.

This is why I wanted to eliminate the theory of this being related to Netlify Identity Widget vs GoTrue JS.

EDIT: Nevermind, I was able to find the error using the error id. This is the error I can see:

error = "Error sending confirmation email: dial tcp 64.233.181.27:587: i/o timeout"

I checked that IP and it belongs to Google:

So for some reason, the connection is failing.

I have changed the no-reply email configuration with a different approach to authentication, but it seems also not to work.

Please try again to check whether the error logs are improved.