Home
Support Forums

Configuring Custom no-reply email

(Personal opinion: You require far too much data to expose to the public to get support, so I am withholding some information. You have access to my account and site and can see the real values. Perhaps this is not the case with a Pro account, and no offense intended.)

Site: domorobo.to

Feature: Outgoing email address

I tried to use a custom email address: no-reply@mycompany.com

Sender email address: no-reply@mycompany.com 
  - This is an alias for my company email address (see below Server login)
SMTP server host: smtp.google.com
SMTP server port: 587 (default)
Server login: me@mycompany.com
Server password: [pw for me@mycompany.com]

It appears that this does not work. We are also trying to set up our custom OAuth dialog form, etc, and we are getting this error from GitHub app:

Redirect URI Mismatch:

http://your-application.com/callback?error=redirect_uri_mismatch
  &error_description=The+redirect_uri+MUST+match+the+registered+callback+URL+for+this+application.
  &error_uri=/apps/building-integrations/setting-up-and-registering-oauth-apps/troubleshooting-authorization-request-errors/%23redirect-uri-mismatch
  &state=xyz
  • How do I test whether my no-reply@mycompany.com is working given that we have a problem with our OAuth?

  • How do I reset to the default no-reply@netlify.com? This currently doesn’t work because the settings dialog does not allow me to clear the fields. There should be a Reset Defaults button that also auto saves.

Thanks for your help :slight_smile:

Amazing. I just found that possibly 465 is the expected port for smtp.google.com.

I still need to know how to test any such configuration without our custom authentication dialog with OAuth working.

Hi @VaughnVernon,

As requested in the other thread, the settings have been reset.