Custom sender address: Error recovering user

I have an error setting up the Custom sender address, but keep getting this error:
Screen Shot 2021-03-10 at 11.43.32 AM

it was working with the default and I can’t get back to no-reply@netlify.com so it’s now broken.

I had level 1 auth, but it wasn’t working, tried to go back to default so at least no-reply@netlify.com works, but that’s broken as well.

site: mento-production dot netlify dot app
dns: mento dot co

I’ve followed the docs, but they are thin on this subject. Identity-generated emails | Netlify Docs

any help would be greatly appreciated.

[edit]: we are using gsuite email server.
[edit 2]: get this error when trying to reset password from the admin console in netlify: {“code”:500,“msg”:“Error recovering user”,“error_id”:“4c18f9fc-2b74-4692-b9c5-018cf2def9f6”}
[edit 3]: i’m able to log into the email account with the same credentials as I am giving to netlify…

hi there, can you tell us a little more information please? which site is this regarding, for example? Also, it might be helpful if you could describe what you are trying to accomplish in a different way, I am a little confused. :sweat_smile:

@perry Thanks for getting back to me.

the site: mento-production dot netlify dot app

I am trying to setup a CUSTOM OUTGOING EMAIL address under IDENTITY.

The issue is that when a user tries to recover their password (and thus a custom outgoing email is triggered) there is an error (see above post).

hi @JamesHighsmith , thanks for that detail. The person who knows most about Identity is out this week, but i will try and get someone else’s :eyes: on it. Thanks for your patience, and do let us know if you make any progress in the meantime.

Hi, just to get you unblocked, I went ahead and reset your identity instance’s smtp configuration. That should at least let you use the default email settings.

I’m stilling looking into what the cause of the error was. Will update in a bit.

Ok, so based on our logs, those password recovery attempts failed due to the smtp username and password not being accepted by your email provider. You’ll want to check those before trying to re-add your smtp configuration.

Hope that helps.

@Dennis So, I’m getting this error and haven’t touched the settings yet after you reset: {“code”:500,“msg”:“Error inviting user”,“error_id”:“85e9f402-a1e3-4b01-be29-d0b7ef6ebaac”}

I believe may need to generate application-specific passwords: Sign in with App Passwords - Google Account Help

For the gmail account you’re using, this will need an “app password” and you can set this as the SMTP password in the Netlify config :+1:

1 Like