My posts are not updating and new posts are not added to my site

When I update existing posts and add new posts, deploys are published without issue. However, for some reasons my posts do not get updated or new post do not get added to my site. I have no issues updating other sections of my site.

My netlify site name is Could you help identifying issue?

Thank you

Hi @minr, and welcome to our community!

You seem to have renamed or removed the site so I can’t find it to take a look. Mind sharing the new name with us?

Hi - I deleted the site and started all over again. It’s working now. Thank you for the reply.

Hi @fool - Sorry I spoke too soon. I tried to update again, site is still not updating.
Name is

Thank you

As far as I can tell (I have a reliable way to check), we are serving the latest deploy on all of our CDN nodes.

So it sounds like perhaps we are not building what you intend, and thus not serving it. Could you download a copy of your build and confirm that it matches what you get when you build the same commit locally? You can download a copy of any commit from its logs page (e.g. from our last build), from the icon shown in this screenshot: