More name servers on a custom domain


I am writing regarding one issue that I encountered trying to setup a CNAME for a site hosted on Netlify.

I am using a custom domain, .app, and following the documentation, I tried to add Netlify name servers on my domain provider’s panel. My issue is that I cannot add any more name servers, since there is already a set in place.

I have a CNAME set that points to the Netlify site name, but accessing it, prompts me an error related to security, “Your connection is not private”.

I hope to find a solution for the encountered issue, and I am looking forward to your suggestions.

Thank you in advance! Welcome to the Netlify community.

To use Netlify DNS, you do not “add” them to the DNS on your registrar’s DNS settings page, you replace your registrar’s DNS servers with the four Netlify servers. On NameCheap, for example, setting Netlify to handle DNS looks something like this:

You can see that there are three options: Namecheap’s built-in DNS, DNS to use when you are also using Namecheap for hosting, and custom DNS. Netlify’s DNS entries fall under the custom DNS option. (You can just see the last of the four Netlify DNS entries peeking out beneath the drop-down menu.)

Note that if you have any other DNS entries in your registrar’s DNS dashboard (such as MX servers, TXT entries, CNAME verification entries, etc.), you’ll need to transfer those over to Netlify, as none of the DNS entries with your registrar will be honored once you switch to the Netlify DNS.

Thank you for your answer!

That is my actual issue. There is not an option in my case to use Netlify DNS, so is there any chance to use it without changing my current name servers? You bet. Here’s the documentation:

@gregraven Thanks! This is what I have tried to do by now. After setting up the CNAME and trying to access it, I have the security issue saying “your connection is not private”

You might want to check out this handy guide:

I’ve looked at your account and I can see that the site is still being served by OpenResty. So, if you have changed them to the name servers provided in the UI, we may be awaiting propagation.

I did not change the nameservers as this is not an option for me. Instead I added a new DNS cname record that makes point to When I go to I get an error saying “your connection is not private”.

You’re right, my bad!

You’ll want to add the domain in the Netlify UI :slight_smile:

Ok, I will try that. Thank you!

1 Like

I managed to solve the issue. Thank you very much for your help! @Pie @gregraven

1 Like