Mistake with my github repo that I can't undo leaves netlify pointing to the wrong site

Hello all, I have a single page static site, https://tomtomtattoo.co.uk, hosted on netlify with gentle-lily-225342.

I had a repo on github called tomtomtattoos where my code was held and to which gentle-lily pointed.

I have been updating the site on my own computer using vscode and have turned it from a single page site to a multi page site. I created a new folder for the multi page site and copied my files across and have been working in the new folder exclusively, I named my new folder Tom Tom Tattoos - multipage. I’m not ready to deploy it yet because I still have a lot of work to do.

VS Code has crashed several times today and so I decided to upload my newsite folder to github to ensure that I had a back up for it. I opened a new repo which I called Tom-Tom-Tattoo - multipage and tried to upload my files to it. Unfortunately, VSCode and github between them put the files into the original repo (tomtomtattoos).

Of course, netlify updated and now shows the new site, which I don’t want it to.

So this is what I did:

  1. I deleted the repo Tom-Tom-Tattoos - multisite (at this stage it was totally empty)
  2. I checked the repo tomtomtattoos and found that it had all the new files in it, files which I did not want in there.
  3. I tried, and failed, to undo all this in VS Code , by this stage I could not get it to do what I wanted it to do (up load the original files and delete anything else)
  4. I checked the copy of tomtomtattoos on my desktop and found that it had the new files in it also by now!
  5. I manually fixed the folder on my desktop.
  6. I deleted the tomtomtattoos repo on git hub and made a new repo with the name tomtomtattoos and uploaded my files into it.

I assumed the gentle-lily would point to the newly created tomtomtattoos repo but it doesn’t, it points to the one that I have deleted but still displays the website as though the repo were still there.

Thank you for staying with me. Here’s the question, how do I make netlify point to the correct repo now?

Just in case any other newbies hit the same problem, I have now solved it. I went to the site overview and found that a production deploy had failed - not unexpectedly as the repo it was deploying from had been deleted. I had the option to re-deploy so I took it and pointed it to the new repo I had made - success, it may have been an odd way of doing things, but it worked and the original site is up and running again. Now all I have to do is get my multi-page site working as I want it to!

Thank you for reading, I think writing all this down focused my mind a little.