Manual deploy update turn around time?

I am deploying the external build folder that I create in visual studio code.
The same type of folder that is used to create the app with a ‘manual deploy’.

This is a react app so it’s difficult to upload the files since there’s so many of them.

Is there a better way to update a react app?

The easiest and best way to update apps on Netlify is almost always to use continuous integration (CI, also known as CD - continuous deployment) - that’s a key feature of the platform. You do some work, commit your changes, push to your gir provider, and we automatically detect those changes, build and deploy your site.

It’s much less error prone and once its set up, it is generally stable and reliable.

there are other options as well, such as deploying from a command line tool, but for your use case, i think deploying from a git repo is the best way to go. You can use github, bitbucket, gitlab or azure devops to store your repos.

You link your git repo to netlify, and once that is done, we handle the rest.

1 Like

one key advantage of using CI/CD is that as your sites get bigger and more complex, drag and drop stops working reliably. It’s really not intended for sites with more than a few html pages and a few small images - it’s perfect for “under contstruction” type maintenance pages or small projects, but anything more complex than that it’ll max out pretty quickly. It’s likely, i’m guessing, that this is what is happening here to you and why you keep getting stuck.

1 Like

Thanks for the feedback Perry.

Unfortunately I’m still having problems.
I’ve now connected with my GITHUB repository. I’m getting errors when trying to redeploy and in the end it’s failing to build.

I understand the CD is really a great feature. On my vanilla JS apps it worked flawlessly…However on React I was under the impression it was only possible to create the app by dropping the build folder you create.

When I initially create any react app this method works well I’m confused why it would not work for an update.

and an update…I tried to update via the CLI in VSC.
Whatever it did it seemed to break the code so when I manually deploy the site I get an error.
I’m likely going to be forced to build a whole new react-app and copy and paste everything.

What a pain! is there really no easier way to update react apps? This has turned into quite the frustrating operation.

hi Kyle, I specifically suggested that you use CI/CD for your application and pointed you towards documentation for that, not the CLI - why did you opt to not follow my advice?

The information you have about CI/CD only being for vanilla JS apps is not correct, you can run very complex build operations easily this way.

You will need to have an up to date package.json that includes the build commands and dependencies you need at the root of your project, and you’ll need to have a netlify account so that you can link your git repo to our system. This is the usual setup for 95%+ of netlify customers.

Please share a build log, or site name, or something that we can identify you in the system so we can assist. What is the error you have received?

1 Like

@KyleRomanos It may be unrelated but this user found that .map files in their react app were causing their build to get stuck on line #1.

1 Like

Hi Nathan
I do have some .map functions in the app. Did this user find a way to work around this??

They indicate in the thread that they deleted the files…

1 Like

Hi Perry,
My apologies I didn’t explain entirely. I did attempt the CI/CD method as you suggest and it didn’t work.
According to your documentation the CLI option was next on the list. I tried that and it seemed to make the biggest mess :slight_smile:

After further inspection trying the CI/CD method via github I noticed some errors on the build log.
Issues that had no impact when hosted locally on 3000 were causing error messages in the log.

I couldn’t tell if they were causing the FULL failure but I figured I may as well remove all errors and try again using the method you suggested.

This time it WORKED. now I’m confused why I’ve never been able to successfully deploy my app via CI until now (most likely something with what appeared to be irrelevant errors).

Now everything looks good and updating the site has never been easier.


1 Like

that would not be sustainable for me but either way, looks like everything is finally resolved from Perry’s suggestion.

The main culprit on my side seemed to be a mistake using tailwind syntax on the main CSS file.
It wasn’t giving me errors when hosting locally but it appeared to be breaking the deployment build.

[postcss-preset-env: end value has mixed support, consider using flex-end instead]

@KyleRomanos When it breaks the deployment on Netlify, does it provide no error at all?

I’ve been having the same problem for manual drag and drop deploy in netlify from yesterday. it gets stuck at Creating deploy upload records. I build the app locally and drag and drop the dist folder, but it doesn’t deploy in netlify. I can confirm that locally serving the dist folder works, so there is nothing wrong with my build.

Hey there, @sedghi :wave:

Thanks for reaching out. We have opened an internal issue to discuss drag and drop deploys, and will continue to investigate this with our teams. In the interim, please do not hesitate to share any developments or updates here.

Any one finding this post later, I ended up using the netlify cli netlify depoy and it worked fine, for some reason the drag and drop did not work for me (was working before). I hope this helps people searching here


Thanks for following up and sharing this, @sedghi! This will be beneficial to forums members who encounter the same obstacle.

Glad to find this only 1 day old post, because I faced the same problem today. Last drag 'n drop deploy was on May 23. I did not add any files but only updated existing ones.

Using the CLI is not an option, because it’s a Blazor app and Node.js is not installed as instructed on the “Get started with Netlify CLI” site.

Drag 'n drop deploy worked well on a Hello World test site.

Please let me/us know, when drag 'n drop deploy is possible again. I’d like to deploy latest on Friday…

Many thanks!



1 Like

Thanks for sharing, @Philipp! Sorry to hear you are facing the same obstacle. We will follow up when the error is resolved.

Hello @Philipp - The issue impacting the Drag & Drop deployment method has been resolved. Please do attempt to deploy via Drag & Drop at your earliest convenience.

You can read more details and continue the conversation here: FIXED!: Drag & Drop Issue Status & Workaround

1 Like