Large Media Image Transform isn't working, Images are returned at full resolution


I ran into an issue with Netlify Large Media while working on this site: When I link to an image with an nf_transform parameter, the transformation doesn’t happen – instead, the image is returned at full resolution.

I see the same problem in Netlify CMS, which also displays the images at full resolution instead of their thumbnail versions. This tells me it’s probably not an issue with my frontend code.

Some things I tried:

  • I followed the setup instructions from the documentation and got no error messages
  • I checked if my images are tracked using git-lfs ls-files: they are.
  • I checked if the images are LFS pointers in my Github repo: they are.
  • I can see the image files in the Netlify admin (although there are some duplicates, not sure if that’s part of the issue)

Any ideas on how I might solve this? Thanks!

Hi, @awesomephant. I don’t know if you changed something but I’m seeing it work when I test:

Here is a full size image using

Same image transformed 400 pixels wide using

200 pixels wide using

If you are seeing something different, what URLs are you using?

Yes, I noticed it start working this morning, too! Is it possible the service might just take a while to “spin up”? Anyway, thanks for looking into it @luke, I’ll mark this as resolved.

1 Like