Support Forums

Issue with the mobile version of website


When I access my website through the *.netlify.com or *.netlify.app domains on my mobile phone, it will show the mobile version of the website correctly. But, if use a custom domain (e.g., one I get from name.com), the website is not rendered in mobile version.

Website: gastonfermandois.netlify.com
Custom domain: gastonfermandois.com



You’re having this problem because your custom domain points to a custom page that embeds your Netlify site in a frame, and said custom page does not have the viewport meta tag in its source code to let mobile browsers know that it is responsive. While the pages on your Netlify site do have this meta tag, it is ignored inside a frame.

First, your custom page is using the old HTML 4.01 standard from 1999, using the obsolete frameset and frame elements. Also, this framing solution prevents linking to other pages of your site from your custom domain. You should consider deleting that page altogether because of these issues.

As for a proper solution, I would recommend setting your custom domain as a domain alias in your Netlify settings, and modify your DNS records to directly point to your Netlify site. You can find more information about this on the Netlify Docs section about custom domains.

Hope this helps! :grinning:


Hi, @gferman, and welcome to the Netlify community site.

@SmashManiac has given a very detailed (and correct) answer. Thank you for researching that and answering so thoroughly!

If you want that custom domain to point to your Netlify site, @gferman, would you please try the instructions here?

If that doesn’t resolve the issue or if there are other questions, please let us know.

1 Like

Thanks @SmashManiac and @luke for your help! I’ve tried both of your recommendations, but I’m having trouble with the DNS configuration. Currently, my custom domains configuration is the following:

A “Check DNS configuration” message appears close to the Domain alias. The DNS configuration asks me to point www CNAME to gastonfermandois.netlify.com

I attach some screenshots so you can see my current configuration in the custom domain provider:

Finally, regarding the comment from @SmashManiac about some obsolete HTML frameset, I am currently using Hugo’s Academic website builder (https://sourcethemes.com/academic/) and deploying the files in GitHub. I don’t have much control on the HTML standard being used beyond that. I appreciate your comments on this matter.



What I would recommend is:

  1. Add your apex/naked custom domain as an additional alias in Netlify.
  2. Replace your A record at the apex/naked level with Netlify’s load balancer, as detailed in the link both me and luke posted. Right now it’s pointing to a different IP address which hosts the bogus custom page.
  3. Delete your wildcard (*) A record - it also points to the bogus custom page, and unless you expect your users to type in random subdomains other than www, it does not provide any value.

I’m not familiar with Hugo’s Academic website builder, but I doubt it has anything to do with this problem, as the problematic custom page is a completely different website than your main one.

I don’t know why you have set up these weird A records, but they’re the ones causing the issue, and whatever website they’re pointing at is the culprit. I’m curious to know if it’s linked to a “redirection” feature provided by your registrar.

No need to censor the screenshot by the way - anyone can query the DNS system to retrieve the information stored in your DNS records.


I’m having the same issue only my site is made with Gatsby. The website loads without any problems while on wifi but starting it on mobile internet is impossible. I deployed a site on netlify earlier and there were absolutely no problems.
My domain settings below

domain settings

I already tried what has been posted here but to no effect. I really need some help, I’m going crazy out here.

Hey @luznykarol and welcome!

You have a screenshot from a DNS host that is not Netlify, but you also seem to have Netlify DNS configured here: https://app.netlify.com/teams/karol-rudzinski1990/dns/cozycollective.pl :face_with_monocle:

Have you switched over since writing in?

And can you explain a bit more what you mean by “impossible”? Is it very slow but does eventually load? Or you just see a blank screen?

Thank you for the welcome and I’m sorry about the total lack of knowledge on this matter. By impossible I mean that at first the site (we’re talking mobile only on the .pl domain) was showing a 404 google error while viewing it on wifi or mobile while using .netlify.app domain worked perfectly fine.

Also, should I delete the config I posted and leave only the netlify dns settings, what am I missing?

No worries at all. It looks like you’re set up correctly to use Netlify DNS, so we can continue to host the DNS records for you. You shouldn’t need the A record for or the CNAME for cozycollective.netlify.app anymore since you seem to be pointing to our nameservers already :+1: (we need one or the other- either A + CNAME pointing to us for keeping your existing DNS host, or NS records pointing to us for using Netlify DNS).

Looks like having both at one point created an SSL problem so I’ve just reissued your SSL certificate. Could you please give the site a try on mobile again?

I’m having a similar issue to the original post. My website can be accessed from a custom apex domain on a Wi-Fi connection, but on mobile data it can only be accessed with the “.netlify.app” domain or with the “www” subdomain.

I’m using Netlify DNS, So I think the link @luke gave and the recommended steps from @SmashManiac are if I wasn’t using Netlify DNS?

The domain’s registered at Namecheap. The nameservers at Namecheap’s “Advanced DNS” section are set to the default “Standard Nameservers” option.

I think this may be an issue with a DNS record, but I don’t know. Any ideas?

which domain is this regarding, please?

The domain is chiever.life

Hi, @slanden. My best guess is that the mobile device is using IPv6 (instead of IPv4) and this DNS zone doesn’t have IPv6 enabled:


Would you please try clicking the “Enable IPv6” button on the page above to see if that resolves the issue?

If it does not resolve it or if there are other questions, please reply here anytime.

@luke that seems to have fixed it, thanks!


@jen Thank you for such a fast response! The site works perfectly, however now sending an email on my mail (hi@cozycollective.pl) does nothing. By nothing I mean I’m not recieving any emails, no matter where I send them from. Is this connected to the DNS settings aswell?

Hi there! This Support guide is the best place to get started with information on dealing with email on Netlify:

If you still have questions after working through this guide, we suggest you try the search, as many people have already asked questions on this topic. If still no luck, let us know and we can troubleshoot with you.

Hi again! I followed the link you provided, and I added MX, TXT and SPF records to my netlify admin panel. Since from what I see it takes some time to apply, could you please check if my settings are correct? If it’s possible of course :slight_smile:

Hi, @luznykarol. I can see that all the DNS records listed in this DNS zone do work as entered. However, I am not able to tell you if the DNS records created are the correct DNS records or not (with the exception of NETLIFY and NETLIFYv6 type records)

To be clear, you need to tell us what records are correct as only you have access to that information. We are only your DNS service for this domain and not the email service. We can confirm if DNS records are working as entered but we cannot tell you what the correct records are for your email service. Your email service should be able to tell you what DNS records are required.

If you share the list of required DNS records with us, we can help you get them entered and working. If there are other questions or concerns, please let us know.