Custom domain working on some devices but not other


I have a custom domain transferred to Netlify DNS. I can access the website through the custom domain on some devices (e.g. my work laptop, my iPhone) but not others (e.g. my personal laptop, my iPad)

I have a Netlify site that is deploying fine (via GitHub) from its default subdomain:

I purchased a custom domain on Hostinger,, and have followed all the instructions to transfer it to Netlify DNS. This appears to have been successful as far as I can tell. The Netlify DNS badge is appearing next to the domain in the custom domains for my site section. An SSL/TLS certificate has been generated. I’ve updated the nameservers on Hostinger, as instructed. The domain is showing as externally registered at

However, on some devices and browsers I can access the site through the custom domain. On some I can’t.

For example, loads fine on my work laptop, but on my personal laptop I get the error “Safari can’t open the page “” because the server where this page
is located isn’t responding.” I get similar issues in other browsers. Both computers are MacBook Pros running macOS 12.6, on the same WiFi network. Also, the custom domain is working on my iPhone but not my iPad - both are up-to-date. The site loads on my sister’s phone, but not that of a friend. It loads on a friend’s computer, but not on my partner’s. I can’t make head or tail of it.

If I type into a browser (without the https://) into a computer/device where there site isn’t loading, then I get to a Hostinger page saying the domain is active and using Hostinger nameservers, even though I’ve definitely updated to the Netlify ones.

What I’ve tried on my personal laptop:

ellakaye@Ellas-MacBook-Pro ~ % dig  NS +trace | tail -n 6		3600	IN	NS		3600	IN	NS		3600	IN	NS		3600	IN	NS
  • Checked whois, which also gives the correct nameservers
  • cleared the browser cache and cookies
  • flushed the DNS cache following the instructions at
  • updated to macOS 12.6.1
  • turned my computer off and on again!

Any insight or help would be greatly appreciated. Thank you very much.

In the time-honoured tradition of seeking help online, no sooner have I asked this question than the situation appears to have magically resolved itself. I can now load the website on all my devices.

The amount of times this happens to me… and I run an internet forum :laughing:

We are glad you came back and let us know that everything is working now. Don’t hesitate to post in the future should you encounter other questions or concerns! Happy building :rocket: