Issue where the files in Netlify Large Media stay as pending upload forever

Hi,

I’m currently experiencing an issue with Netlify Large Media where the files in the repo are uploaded to Github as full files (instead of pointers) and the files show up in the Netlify Large Media tab but stay as “pending upload” forever.

My netlify instance is: tailwindmade

I was previously using Github’s LFS but I uninstalled it and then installed Netlify Large Media. May this be the reason for the problem?

Hi, @viviangb.

Would you please try removing the files from the git repo and then adding them back to tracking again? Here are the GitHub instructions for this (but this also applies to Netlify Large Media):

https://help.github.com/en/articles/moving-a-file-in-your-repository-to-git-large-file-storage

If removing and then adding the files to tracking again doesn’t resolve the issue, would you please open a support ticket about this issue by emailing support@netlify.com?

I just ran into this issue because I was using GitKraken to commit LFS files, turns out GitKraken will point to your Git Provider and not Netlify.

In the original case, there was an issue in our database which needed to be manually corrected. This should be rare but, if you do see “pending upload” with Large Media and it never completes, please reach out to us here. We’ll be happy to take a look to confirm what the issue is.

@luke Happening to me right now, files are pending upload for over an hour.

Also, what is the limit for the total size of the storage, and does the limits from Github LFS (1gb storage, 1gb bandwidth) apply? Sorry I don’t know how it works

How can i access these files in my lambda functions? Over file system, http?

Hmm, we don’t impose any storage limitations (we don’t use github, here), so, pretty sure their limitations aren’t the issue.

The files will be accessible only over http. there is no concept of a “file system” for them either in a function, or even during build: they are pointers to files during build rather than the file themselves, and only the “deployed” copies are actually going to return content.

@fool The pending upload issue is fixed.

What’s the URL for LM files? I was given an endpoint in my project UI (https://my-site/.netlify/large-media), but it requires Authorization header?

Update: Sorry, I got it now. The data is available on https://my-site/datasets/**

Thank you for the update! Yes, the files must be copied to the publish directory during the build and they are then available at their respective URLs after the deploy is complete.

I’m having a similar issue here. If I add new files they upload okay, but with the previous files, even if I remove them from git and add them back they’re in limbo.

This is maybe based on the SHA hash? Because if I make an extra copy, they’re equally stuf.

I worked out that if I modified the images slightly, that would change the SHA hash, and allow them to be uploaded again, such that they can show up.

One feature request that would be nice, would be for users to have the ability to delete large media from the server. That way, if I was in this situation, I wouldn’t need to alter & re-upload the images, and I could also have more control over my storage usage.

Hi, @Steve2, what do you mean by “in limbo”?

If these are files which were stored with a different Git LFS service and then moved to Large Media, the solution to upload them Large Media is normally running this command:

git lfs push --all origin

Is that what you were trying?

I have the same problem, large media file is in pending state for a while - https://app.netlify.com/sites/rear-window/large-media

@luke

update: netlify login, logout, add another file. It works now

Hi, @volyx. Did you try the suggested command above?

git lfs push --all origin

If so, what happened when you tried this?