My video doesn't work

Site :

Hi, I followed all the recommendations on this post : [Support Guide] Troubleshooting your Netlify Large Media Configuration

I have nothing to display on the site and the large media tab, the pointer is well in place on github.

thank you for your help !

Hi, @Hiliyeh, would you please test running this command in the local repository directory?

git lfs push --all origin

My best guess for the root cause of the issue is this:

  • The files are in the repo but haven’t been pushed to the new Git LFS service (our Large Media service instead of GitHub’s LFS service).

If that is the root cause, this command will upload the files to our service as well.

After running that command, please commit a change to the site repo to trigger a new build and deploy. If that new deploy still doesn’t work, would you please private message (PM) the output of the following command to me? (It is the same command with debugging output.)

GIT_TRACE=true GIT_CURL_VERBOSE=true git lfs push --all origin

However, I hope that won’t be needed as I hope the first command resolves the issue. :slight_smile:

Please feel free to reply either way and if there are questions, we will be here to answer.

1 Like

Hi @Hiliyeh, from the logs sent it appear that Git LFS file locking is enabled. Large Media doesn’t support Git LFS file locking.

The solution for that issue will be to disable Git LFS file locking or to stop using Large Media.

If you want to disable Large Media for this site, that is a manual process only our support team can do. The only workaround via our web app is to delete the site and recreate it. The new site won’t have Large Media enabled. Again, our support can also remove it from the site without deleting the site.

To disable Git LFS file locking, run the command below:

git config lfs.locksverify false

Would please let us know how you want to proceed?

Hello, I’m going to disable the lockdown.

Hi, @Hiliyeh, after removing the locksverify setting, please try the git lfs push --all origin again and then trigger a new site build at Netlify.

If it still isn’t working, please let us know.

The “git config lfs.locksverify” return is " false "and I tried.
lfs push --all origin " then I redeployed but the video does not appear.

Hi, @Hiliyeh, what is the URL for the video which isn’t working?

the div that contains the video does not appear in the dom .
I don’t have any problems locally.

Hi, @Hiliyeh, that file doesn’t appear anywhere in the deployed files. This is the list of files in that deploy:


Also, the site HTML itself makes no reference to that file.

This doesn’t sound like a Large Media issue as much as this sounds like a build issue. It is a private git repo so I’m not able to test building myself.

Why doesn’t the site build contain the same file the local build does?

To troubleshoot and find the answer, I would clone the repo to a new empty directory, then run the dependency install, then run the build command.

Once that is done, compare that build to the site at Netlify. If the local build has the same issue, then you’ll need to resolve that locally as the issue isn’t at Netlify. Once the local issued is resolve then try the Netlify build again.

However, if the fresh clone works and the Netlify build still is not working, then it is time to look for differences in the two builds. For example, are the node versions used the same? I see v12.18.0 used in the most recent build here.

Last but not least, does you build try to process the MP4 during the build (like resizing or embedding the video as base64 encoded text in the HTML)? If so, this won’t work with Large Media as described in the limitations section of the documentation:

Files tracked with Large Media are uploaded directly to the Netlify Large Media storage service on push, completely bypassing the site build. This saves build time, but also means that the files are not available to tools that process asset files during the build, such as Hugo’s image processing or the gatsby-image plugin. Depending on your needs, you may be able to replace this functionality with Netlify’s image transformation service.

Please let us know if there are other questions about this.

1 Like

Hey, luke! I followed your recommendation, I have a media file with the video after a local build, which is not in the online site.I don’t understand why. The node version fits. but locally and at netlify I had no problems before using large media and git lfs.
I don’t do any processing on the video.

Thanks for your help, luke. I’ll look for another way to solve this problem. :slightly_smiling_face:

Hi, @Hiliyeh, we can remove the Large Media add-on for this site and you can change to using GitHub’s LFS service instead if you prefer.

In other words, you can still use Git LFS but not Large Media if you want to. Large Media is one Git LFS service and it is one option. However, using the Git LFS service from the upstream repo host (GitHub in this case) is also always an option. You don’t have to use Large Media to use Git LFS for a site at Netlify.

If you want to uninstall the Large Media add-on please read this guide and then reply here anytime to let us know we should proceed with uninstalling it.

1 Like

Hi Luke! Thanks for your help; I want you to uninstall large media for this site :slight_smile: Thanks again

Hi, @Hiliyeh.

We have removed the Large Media add-on from this site.

Would you please push the commit removing .lfsconfig to the upstream repository? This will trigger a new build.

Please let us know if there are any issues with the new build or deployed site.

1 Like