Integrate Hashnode with Netlify website - Adding A records

hi there, we flipped a switch that will allow you to first delete and then add a new A record. Let us know if you need more assistance.

Thanks. What will happen if I delete the record “jacobcollinsdev.com”? Will that mean that that URL will no longer redirect to my website www.jacobcollinsdev.com? And if so, would I be able to add it again afterwards?

hi there, once you have deleted the A record, you will be able to add a new one to point to the right place. You should immediately add a new record to avoid downtime.

You can read more on A records here:

I don’t know a lot about HashNode, can you explain a little what it is? I wonder if there is a better way to accomplish what you are trying to do without messing with the A records :thinking:

HashNode is a blogging platform, but they also offer you the ability to host the blogs you write on your own website. So you create the article on HashNode, then it gets published to Monsterhost.com Blog – Sitebuilder, Web Hosting & Website Tools. They need you to add an A record so they can push your article to your website I’m assuming.

Once I’ve added the new A record from HashNode, will I be able to re-add the record I deleted initially?

Hey @jacobcollinsdev,
Are these the instructions you’re following?

or could you please share the ones you’re using?

The setup you describe would mean that your apex domain (jacobcollinsdev.com) will no longer redirect to your website at www.jacobcollinsdev.com. One better option may be creating a CNAME record in your Netlify DNS panel for blog.jacobcollinsdev.com that points to your HashNode blog.

Another option would be to instead proxy to that blog. Then you wouldn’t have to fiddle with DNS so much- you’d just route requests to www.yoursite.com/blog/* to your HashNode blog under the hood. Here are our docs on that:
Rewrites and proxies | Netlify Docs

Let us know what your preference is and we’ll help you get set up!

Hi, the instructions I followed appear when adding the domain on the HashNode dashboard and read as follows:

"CNAME instructions (Please read the details carefully)

Head over to your DNS provider and add a CNAME record where the host name is @ and the corresponding value is hashnode.network . We’ll automatically provision an SSL certificate for you when you visit your blog for the first time. If you are using something like Cloudflare, please bypass it for this domain .

:bulb:It’s not recommended to use CNAME record at root level. If you intend to do so, please make sure your DNS provider supports CNAME flattening. If you are still unable to do so, you can add an A record at the root whose value is 192.241.200.144 . However, you will lose the benefits of our global CDN and edge caching with this approach.

:warning: If you are changing or deleting your domain, be sure to remove the old CNAME/A record from your DNS."

I’m thinking I’ll go with adding a CNAME record for blog.jacobcollinsdev.com. Could you please advise on what the CNAME fields should be filled with?

Great! Could you give this a try in our UI here: Netlify App? Click “Add new record” and then your CNAME will look like this:

The records can take 24 hours to propagate (though they usually don’t take that long) so you may not immediately be able to access your blog via blog.jacobcollinsdev.com.

Thank you, I’ve added the record and set the domain on hashnode to blog.jacobcollinsdev.com. I’ll let you know if I experience any further issues.

Thanks for all your help!

1 Like

Hello jen can you help me.i have set the subdomain in hashnode and set the cname record for the subdomain like this in netlify, but the site (blog.tegvr.com) show ‘not found’ message. The subdomain before is used in one of my site, so i removed it from the site, and create new record. Please note i’ve been waiting for 24 hours also.

Hey @tegvr,
Can you please share the full url of your blog at Hashnode? It will have to be publicly accessible on the internet in order for the DNS record at Netlify to point to it.

Works now :slight_smile: You had some existing NETLIFY and NETLIFYv6 records set for blog.tegvr.com that were pointing to Netlify sites. I deleted them so that your CNAME for that subdomain pointing to your Hashnode blog would take over. Let us know if you need anything else!

thanks for your help.

1 Like

Hi team!

I am currently in the same spot that these gentlemen were in and I am hoping that someone will be able to help. When I try to add an A record in my Netlify DNS for my samofamcreative site I get this message “dns_api samofamcreative.com - samofamcreative.com/A: 400 - link exists, all config must be empty” but I do not have any other A records. I was able to add a CNAME using the same examples listed here but when I try to open my blog I get an error message on my site like this
errorMessage
. I have waited a couple of days but it is still not working. My hashnode blog is found here Shaun Samoridny — Hashnode

Thank in advance!

Hi @SSamoridny,

I think this guide might help you:

TL;DR:

If you remove the Netlify records, your website as Netlify will stop working. So delete the only if you wish to do that.

Thank you for your reply. Sadly for me I had deleted the NETLIFY and NETLIFYv6 records before seeing this reply. I added the Hashnode record and that began working but as you mentioned above, my original site stopped working. I tried re adding it thinking that it would go back but now I have been waiting for DNS propagation for 3 days and I only had the Hashnode part working. What can I do to try again and more importantly have my original site back being hosted by Netlify? I have truly messed this up.

Update. DNS Propagation is now working and I have deleted the Hashnode record from the DNS. However, the site is still not loading from my Github, it is displaying the Hashnode blog

My original site is up and running again but I am at square one as far as adding my Hashnode blog. I have created the DNS records as instructed but it does not open on the site.

Hi, @SSamoridny. I show it working now here → blog.samofamcreative.com.

Does it work for you as well?

Luke,

Thank you for the response. I was able to figure it out yesterday. After all of my messing around with it, turns out that I needed to add the DNS record before adding the site to the Hashnode dashboard. Their site suggests the opposite but that’s how it worked for me. So yes, my site is back online and Hashnode is finally attached to it. Thanks for checking this out for me!