Error Adding A Record

Hello Netlify Team,

I am currently trying to add an A record to my site. Each time I try to do so I am greeted with the following error:
“dns_api - 400 - link exists, all config must be empty”
Reading here: "link exists, all config must be empty" bug
This is currently unavailable in the UI, so would you all be able to add these records for me, I would greatly appreciate it.

Hey @FTR, we’d be happy to take care of this. Your site will be unreachable until you add another A record. If this is okay, let us know and we’ll delete those internal records. If it’s not okay, please let us know what to replace the old A record with.

Yes, that is completely fine with me! Thank you so much! I will add it once you let me know it is complete

Great, thanks. Should be all set now :slight_smile: let us know if you need anything else.

Hey @jen so I just tried to add it but I am getting the same error

Hi, @FTR, the any domain names will also need to be removed from the site here before it will be possible to make A records for them.

Would you please delete the domain names there and then test adding the A records again?

Hi @luke, I was able to add it after a couple of hours without deleting the domains. I see this warning on my primary domain name (custom).
There’s a Netlify DNS zone for this domain, but no DNS records associated with it. Please contact support for setting up DNS records.
Is this something I need to give time for it to be resolved? Or do I need to delete the domains and start anew?

Hey @luke or @jen, just wanted to not that even with the deletion of the domains I am still getting the above error. Any help with this issue would be appreciated

There’s a Netlify DNS zone for this domain, but no DNS records associated with it.

Hey @FTR,
This is an uncommon setup, so thanks for your patience as we set it up for you! Where things stand now:

Note that because of this setup, which is not really intended/supported, if you add domain aliases or branch subdomains, they will not be covered by your SSL certificate.

Thanks again for your patience and let us know if you need anything else :slight_smile: