Identity reset problems

I just set up my blog based on the 11ty hylia template witch includes Netlify CMS.

When I first set up identity it worked but I noticed my password manager (LastPass) did not offer to save the password as usual.

Then switching to another PC and trying to log in I used the password reset and tried to enter a secure generated pasword. but this fails. Then I tried to reset again and now I do not get the reset emails, even if I uses the send option in the Netlify portal.

I assume these are Netlify Idenity issues, rather than Netlify CMS

How can I get the password reset email?

Please make the identity login dialog work with password managers. I can;t even paste into the password field which is a security issue and a cognitive accessibility barrier.


So when I look at the identiy setting it says I have 0 active users. And I can find no way to make the user active again. I can only assume the incomplete password reset made me inactive.

How do I fix this?

Ah the pass word reset button in the netlify portal worked. I guess you debounce it - which is a pain.

I think I also got confused what active meant.

So were left with the bug with the Idenity Dialog not supporting paste or password managers

It’s not a bug with Identity Widget, but rather inability of password managers to work in iframes, I guess. The widget loads inside an iframe, but other than that, it does everything else that a password manager should be able to use like input type = "password".

And yes, we do debounce emails to 15 mins.

1 Like

Thanks. You might be right about the iframe, though it appeared to be a popup.

But the usual work around, to paste the password, also failed. I just got a single dot appearing and failure.
It takes extra work do disable paste so is something else going on?

For now a made up a less secure but memorable password (not polite - lol)

We haven’t disabled paste, and pasting works fine on other sites that are using the widget. So, something else could be going on there.

1 Like

I’ll dig in next time I have to login. It doesn’t seem to time-out which is nice on my personal laptop.