Support Forums

I can't add the custom domain that I've created to the site that I've published

  1. I have a domain name from namecheap

  2. I’ve created a custom domain (delegated) in my Netlify for my mail and other records in Netlify for the domain name I’ve bought from namecheap

  3. I’ve added netlify DNS servers to my namecheap domain name

  4. I’ve deployed my site to Netlify https://prod-mindfultravels.netlify.com

Now I’m trying add the domain that I’ve created (step 2 above) to the site that I’ve created (step 4 above)

It gives me the above error. I can’t find anywhere else on the control panel where I can add the Domain that I’ve configured to the site that I’ve published.

Please note that I have created the domain in my account and I’m the owner of that domain on Netlify. But it still won’t let me add my domain that I’ve configured to my site that I’ve published

Hey @prashand,

There is already a website associated with http://mindfultravels.net/. You’ll need to decouple that (remove DNS config etc) before Netlify will add the custom domain.

Hi @Scott

Does changing my DNS provider to Netlify name servers in my DNS registrar(namecheap) do that?


That’s exactly it. For simplicity sake, I’d be looking to make use of Netlify DNS too. This little guide should see you through but don’t hesitate to get back to my with any Qs!

Problem is @Scott I’ve already done that, as I mentioned in point 3 of the original post

Could it be that DNS records haven’t propagated yet?

nslookup seems to be fetching DNS records from my old DNS server (AWS) still

Apologies, @prashand, I’m following now.

If you have this custom domain, mindfultravels.net, associated with another Netlify site, you’ll need to dissociate it first. You’ll need to navigate to the appropriate site in your team to remove it:


If this isn’t you and ownership has been claimed elsewhere, the support team will need to dissociate this for you (perhaps @Dennis would be kind enough to help :innocent:)!

Once this is done, you’ll be able to add your custom domain and it should then appear as such:

Thanks for the support @Scott. I’d been pulling my hair out for the last hour. I’d forgotten that I’d added that domain in my personal Netlify account to another site which I’ve been using for dev deployment. I looked in the settings there before posting here and somehow overlooked it. Thanks again. Onto TLS config now…

1 Like