I can’t access my site - SSL certificate error - Connection not private


My site is https:francodalessio.com (Netlify site name is francodalessiocom).

I have registered the domain here at Netlify, so no external vendors/DNS. Everything was working fine a couple of days ago but now I’m getting this error:

Your connection is not private

Attackers might be trying to steal your information from francodalessio.com (for example, passwords, messages, or credit cards). Learn more


I’m using Netlify DNS from day one because I registered my domain with Netlify. The only change I’ve done to DNS is adding a TXT record for Google Search Console, but that was several days ago (and worked fine because my site has been indexed by Google).

I’ve clicked the Renew Certificate button in the SSL settings, but that didn’t work.

What’s the problem here and what can I do to get my site back up as soon as possible?


@francodalessio The only problem I see with your site is that you are using your apex domain as the primary, instead of the www subdomain. It’s loading fine for me in Southern California over https.

Are you perhaps seeing a local caching issue?

What happens when you try to visit your site using a new private / incognito window in your browser?

1 Like

@gregraven Thanks for your answer! I tried Incognito mode on my laptop, but doesn’t work, I get the same error.

On my phone I get a different error: ERR_SSL_PROTOCOL_ERROR. And if go Incognito on my phone, I get NET::ERR_CERT_COMMON_NAME_INVALID

@francodalessio This is what I’m seeing when I type in just your apex domain and let Safari figure out the rest:

Note the lock preceding your domain name.

I get exactly the same results in Chrome and Firefox.

1 Like

@gregraven I really appreciate your time and help, thanks again. I’ve just realized that if I use 4G on my phone (not Wi-Fi), it works. So I guess my internet provider is blocking it? Any idea why this may be happening?

@francodalessio It sounds as though there may be some caching at the ISP level, if not in your router, etc. Something upstream of your browser seems to be serving you outdated information.

1 Like

hi there, this is what i am seeing:

i think it just needed a little more time. DNS can take some time to settle in sometimes, up to 48 hours in some cases. :+1: