I’ve just set up the automatic HTTPS/SSL offered by Let’s Encrypt on the Netlify platform. However when I visit my site (, I receive the error:


I noticed the certificate was issued by Digicert instead of Let’s Encrypt, not sure if this is the issue.

I also have the same issue

The hostname in the website’s security certificate differs from the website you are trying to visit.

Also Issued by digicert.

Redirect is not working? from to https(primary domain)

Note that one of the main reason that our system will issue an incomplete certificate is when there is a multiple conflicting records for your apex/bare domain or subdomain. Making you don’t have duplicate DNS records should typically help resolve issues like these.

What’s the best way to verify that there aren’t multiple conflicting records? I believe this is all setup properly, but I have two domains that I’m trying to point at the same Netlify site, and the Let’s Encrypt certificate is regenerating with only one of the two.

which domains and netlify site is this regarding?

The one it was registering was, and the one it was missing was It looks like this has now been fixed, though. Maybe something with inconsistent DNS propagation at the time? I tried regenerating it a few hours later again and then it worked, but at the time when it wasn’t there also weren’t any visible errors indicating what was wrong.

Mostly an academic question at this point, but I was looking for guidance for how to diagnose myself what was going wrong in that kind of case :slight_smile:


Hey! Yeah, it’s usually just a case of propagation. Tedious but necessary!

Glad you got this resolved.