Hi All,

I have tried multiple thing but I can’t resolve this problem.
At first I manually added SSL info because my previous hosting provider already had a Let’s Encrypt certificate. Once that was expired I tried it through Netlify but no luck.

First I tried the External DNS option. The domain settings say all is well but HTTPS was not working.
Then I tried to use Netlify DNS. The dig command line option says that the nameservers are correct but Netlify keeps stuck on Currently provisioning your Let’s Encrypt certificate for several days now. I can’t cancel it or try to renew and now I’m pretty much out of options.

Can someone help me to solve this problem?
The domain is

Thanks in advance.

Hey @jorik12345,
With all the changes, things got into a weird state in our database, so you were getting messages in the UI that might not have been representative of the state of your cert. Checking here:

shows a Let’s Encrypt cert that was created/renewed 6/17 and is good for three months. This is the cert that’s currently on your site. You should also be seeing the correct information in the Netlify UI now :+1: Let us know if you need anything else at this point!