Error in our production site regarding invalid SSL cretificate!

Some of our users (including myself) are getting error messages when trying to access out site

I’ve tried to renew the cretificate but it didn’t work.
It might be related to the fact that I’ve added new NS records (with ‘blog’ host) to our GoDaddy domain management.

Please help! it’s out production site!

I am facing the same issue. If you check your certificate it shows the netlify provided sub-domain’s name,
not the sites name

did it start like couple of hours ago.
I’ve tried to renew the certificate but it didn’t work.
anyone else having this issue?
what can be done?

I am facing the same issue here. It links to Netlify’s domain directly instead of ours.

Yes, it started couple hours ago. I am also trying to find solutions.

I’m exchanging messages with some guys at Let’s encrypt.
maybe it will give us more info

Let’s Encrypt guys say the certificate is ok , might be a nelify thing.
Were any of you was able to renew their certificate?

Sounds like it is the same as NET::ERR_CERT_COMMON_NAME_INVALID aspirethemes - #2 by carlmjohnson and but it seems to be resolved now.

Yes, It is resolved now!

Hi y’all we have an incident at this time we have deployed a fix.

1 Like

yep! thanks everyone!

thanks for the update


Just as an added updated, if you were impacted, please be sure to update your DNS settings as described here: Configure external DNS for a custom domain | Netlify Docs

Thanks for letting me know. I will do it