Help with custom domain - "DNS Zone already exists"

Hi all, I’m trying to use Netlify DNS to add a custom domain but when going through the wizard, verifying I own the domain, etc., I get the error message,

“A DNS zone for this domain already exists on NS1”

I’ve checked the forums and the closest issues I can find suggest there’s a DNS Zone that needs deleting (see How to remove dangling DNS entries and Can't edit the value of a DNS record of a domain managed by Netlify DNS), but the problem is I can’t see the custom domain in my Manage Domains dashboard.

It seems I’m in some kind of DNS Zone limbo :grimacing:. Is there a way to reset or flush half-setup DNS Zones through Netlify, or do I need a member of the team to step in?

Many thanks.

Hi @codemacabre! Welcome to netlify community!

Have you used your domain on Squarespace or similar web hosting? Note that Squarespace uses the same DNS hosting service as we do and that DNS host (NS1) does not allow your domain to be configured twice on their service, no matter what.

So unfortunately, there is no straightforward migration path, since Squarespace has forbidden NS1 to transfer zones out of their account.

The best path I know is to:

  1. Transfer to someplace like your registrar or Cloudflare that has free DNS hosting
  2. Work with Squarespace to remove the zone from NS1 (really! just removing your account may not be enough!)
  3. Ping us to confirm that it is gone (we can check before you make any other changes)
  4. Move to our DNS hosting if that check comes back successful.

You do not have to use our DNS hosting to host your website though. You can also configure other DNS hosts and it can work quite well:

1 Like

Thanks @laura. I haven’t used Squarespace and my previous web host (Krystal) managed their own nameservers and DNS. I have previously configured nameservers with Microsoft Office 365, so perhaps it’s that. I’ll investigate.

I may have used the custom domain a while ago when I was first testing Netlify (I don’t really recall). Is there any chance that it’s some historical Netlify configuration, or would that show up in my Manage Domains dashboard?

UPDATE: I emailed NS1 themselves to ask what service might have created the DNS zone and they’ve said that it’s within Netlify’s account:

Thank you for contacting NS1 Support.

We have checked the ‘’ zone and see that it is within Netlify’s account on our systems with a timestamp of 2019-11-11 16:30:34 (UTC).

Please re-check with Netlify support regarding this zone. If there are any issues, then they should be able to delete the zone for you to try again. If they are still having issues, then Netlify support can reach out to us directly to rectify the issue if there is anything deeper going on.

Please could someone on staff take a look behind the scenes and see if there’s any rogue configuration somewhere?

Hmm, not sure how it happened but that zone was in our NS1 account and not our database. It was empty, so I removed it and you should be able to use it now.

1 Like

Thank you @fool! Not sure what I did to cause that but everything works as expected now. :tada:

Hi, mr fool :slight_smile: I have same problem for “” - i’ve deleted all nameservers on, but still cant add a custom domain for my project.

hi there, which netlify site is this regarding? What have you already tried?

Hi, thanks for replying, I’ve already connected my custom domain, but when i click on link from whatsapp, i get this browser warning (below). Why this happens?

Hi, @gerayzade. This was happening because the SSL certificate only covered the root/apex domain. To resolve this I clicked the “Renew certificate” button found under Site Name > Settings > Domain management > HTTPS.

Is the site working as expected now?

Hello, I have the same issue too, I deleted all my dns on, but I still get the error. The domain is please help

hi @aybee, are you able to click “renew certificate”? what happens if you do?