GitHub status not updating Header and Redirect rules

Hi Support-Team,

our builds seems to run and deploy just fine, but the GitHub checks are not getting from yellow to green or red and I can’t find any information or logs about this.

This doesn’t seem to happen always, but it’s getting annoying now. I see there was an issue with this about four years ago, maybe we see a regression here? Flaky GitHub status check reporting

Is there something where I could find out more about these tasks and why they aren’t finishing?


hi @joern.bernhardt

We’ve reached out via email. I’ve seen a similar case where disabling post processing helped:

Alternatively, you can disable the need for these checks on the branch in github like this:

Settings -> Branches -> select protected branch -> "Require status checks to pass before merging


Hi Gualter,

thanks for the quick response.

I don’t see our project using the asset optimization feature at all. There is no build.processing in the netlify.toml. This hasn’t been an issue until very recently (yesterday) and we’re deploying multiple times per day usually. This is definitely flaky. Sometimes it goes through, sometimes it doesn’t. While doing simple PRs, I can add an empty commit to trigger a re-run and this can change whether it works or not. But now when we want to do a PR from one branch to our production branch and it fails there, we need to get it through multiple levels of these flaky checks, which doesn’t really work anymore…

This is how the status checks look like (we waited for hours and status did not change):

This looks like there is no reporting back to GitHub whether the checks were successful or failing. The other forum entry I’ve linked, seems to have been fixed by some backend change on Netlify, so I’d assume we’re seeing something similar now?

Is it possible to debug this somehow?
What does “Pages changed” do? What does “Header rules” do? One of these two seems to hang for us. When looking at Details, there is just a link to the Netlify deploy page and I don’t see anything wrong with that.

We want to keep requiring the other status checks, so I don’t think disabling the status checks in general is a viable option for us. If I have to merge manually, overriding these checks manually, this could be a workaround for now. But since I don’t know what those checks do, I can’t really merge anything to production as I’m afraid it could break something because something didn’t went through on Netlify’s side… :grimacing:

Thank you for further clarification and other solution ideas :sweat_smile:

Just to follow up here, communications outside of this forum post indicate that this issue is resolved with no specific action taken by Netlify or your team @joern.bernhardt.

Based on this, it appears that some transient communication issue between Netlify and GitHub have been resolved.

I do see reports of an incident at GitHub involving the processing of webhooks here:

Does the timeline of that incident align with the timeline of the GitHub checks issue?

We have seen the issue on Wednesday for the first time, not just recently or for a short period of time. The last time we had this issue could have been in their time frame, but we have merged that last PR using admin privileges now. I can’t test this anymore, but we will see next week whether it still happens or not. I’m not confident thath this was our problem.

This question is still open for me: What do “Header rules” and “Pages changed” check?
I just want to ensure overriding these checks when they don’t finish (after the build / deploy preview went through) doesn’t hurt anything…


PS: Btw, GitHub status mentioned “Customers may see a delay of about 5 minutes” - we have waited for these checks to finish for multiple hours and it never changed to being successful or failed

Header rules simply count and validate all custom headers: Custom headers | Netlify Docs

Pages changed shows the number and list of pages that changed in this new deploy as compared to the old one.

Both of these should be non-crucial for any workflow unless you explicitly use these values.

Thank you @hrishikesh , at least we can merge with admin privileges now without having to worry too much that something breaks completely. I’ll check next week with the next PRs if the problem still persists. My hope is that there just was some hiccups as I don’t see any change related to header files

We have two new PRs and they still have “Pages changed” not updating to successful or failed status. So this issue is still not resolved and keeps us from having approval checkmarks from the automated checks.

How we can debug this? What information can we provide to help the investigation?

The “View more details on Netlify” only gets us to the deploy log page on Netlify. Over there, we don’t see any issues with the deploys.


Hiya, it looks like you had a ticket in our helpdesk. Please refer to ticket # 225194

Hi @SamO,

I know there were multiple emails being sent and even one person seemed to be interested into fixing this. But the last update I got was four days ago and saying that it’s still not resolved. I could still see issues with pull requests not finishing the mentioned two checks.

If there is anything we can do to help debugging this, please let me know. This has been open for over two weeks now :frowning:


This issue has already be escalated to the devs. @SamO only mentioned the helpdesk ticket because it doesn’t make sense to debug the same issue on two different platforms. We’d follow-up with any relevant information in the helpdesk.