Home
Support Forums

Github deploy is published and viewable in 'preview' mode but not on live site

Hello,

I made a few small changes to my site and deployed, the site shows it as published and my changed are viewable when I ‘preview’ the app but not when I look at it live. I tried clearing the cache and redeploy but I’m not sure what else I should do. I would be grateful for any advice.

The changes I was trying to make was to remove a google play button and add an email subscription, please take a look at the links below

  • Site Link: https://www.peakperformanceskating.com/#getapp
  • Site Preview https://5fa9b668cd5e750007f5caa0--peak-performance-skating.netlify.app/#getapp
  • Here is the deploy log:
4:45:47 PM: build-image version: 253f72909528f25a82c4640ca58f2e974d52abd9
4:45:47 PM: build-image tag: v3.4.4
4:45:47 PM: buildbot version: 4d1101089482be782418555b0745df5bb257fe50
4:45:48 PM: Fetching cached dependencies
4:45:48 PM: Starting to download cache of 300.8MB
4:45:49 PM: Finished downloading cache in 1.486806381s
4:45:49 PM: Starting to extract cache
4:45:59 PM: Finished extracting cache in 9.421497928s
4:45:59 PM: Finished fetching cache in 11.000147591s
4:45:59 PM: Starting to prepare the repo for build
4:45:59 PM: Preparing Git Reference refs/heads/master
4:46:00 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'build' versus 'build/' in the Netlify UI
4:46:01 PM: Starting build script
4:46:01 PM: Installing dependencies
4:46:01 PM: Python version set to 2.7
4:46:01 PM: Started restoring cached node version
4:46:04 PM: Finished restoring cached node version
4:46:05 PM: v10.23.0 is already installed.
4:46:05 PM: Now using node v10.23.0 (npm v6.14.8)
4:46:05 PM: Started restoring cached build plugins
4:46:05 PM: Finished restoring cached build plugins
4:46:06 PM: Attempting ruby version 2.6.2, read from environment
4:46:07 PM: Using ruby version 2.6.2
4:46:07 PM: Using PHP version 5.6
4:46:07 PM: 5.2 is already installed.
4:46:07 PM: Using Swift version 5.2
4:46:07 PM: Started restoring cached node modules
4:46:07 PM: Finished restoring cached node modules
4:46:07 PM: Started restoring cached yarn cache
4:46:07 PM: Finished restoring cached yarn cache
4:46:08 PM: Installing NPM modules using Yarn version 1.17.0
4:46:08 PM: yarn install v1.17.0
4:46:09 PM: [1/4] Resolving packages...
4:46:09 PM: success Already up-to-date.
4:46:09 PM: Done in 0.77s.
4:46:09 PM: NPM modules installed using Yarn
4:46:09 PM: Started restoring cached go cache
4:46:11 PM: Finished restoring cached go cache
4:46:11 PM: Installing Go version 1.12
4:46:11 PM: unset GOOS;
4:46:11 PM: unset GOARCH;
4:46:11 PM: export GOROOT='/opt/buildhome/.gimme_cache/versions/go1.12.linux.amd64';
4:46:11 PM: export PATH="/opt/buildhome/.gimme_cache/versions/go1.12.linux.amd64/bin:${PATH}";
4:46:11 PM: go version >&2;
4:46:11 PM: export GIMME_ENV='/opt/buildhome/.gimme_cache/env/go1.12.linux.amd64.env';
4:46:11 PM: go version go1.12 linux/amd64
4:46:11 PM: Installing missing commands
4:46:11 PM: Verify run directory
4:46:12 PM: ​
4:46:12 PM: ┌─────────────────────────────┐
4:46:12 PM: │        Netlify Build        │
4:46:12 PM: └─────────────────────────────┘
4:46:12 PM: ​
4:46:12 PM: ❯ Version
4:46:12 PM:   @netlify/build 5.2.1
4:46:12 PM: ​
4:46:12 PM: ❯ Flags
4:46:12 PM:   deployId: 5fa9b88ab772a30008b6eba9
4:46:12 PM:   mode: buildbot
4:46:12 PM: ​
4:46:12 PM: ❯ Current directory
4:46:12 PM:   /opt/build/repo
4:46:12 PM: ​
4:46:12 PM: ❯ Config file
4:46:12 PM:   No config file was defined: using default values.
4:46:12 PM: ​
4:46:12 PM: ❯ Context
4:46:12 PM:   production
4:46:12 PM: ​
4:46:12 PM: ┌───────────────────────────────────┐
4:46:12 PM: │ 1. Build command from Netlify app │
4:46:12 PM: └───────────────────────────────────┘
4:46:12 PM: ​
4:46:12 PM: $ yarn build
4:46:12 PM: yarn run v1.17.0
4:46:12 PM: $ react-scripts build
4:46:14 PM: Creating an optimized production build...
4:46:25 PM: Compiled successfully.
4:46:25 PM: 
4:46:25 PM: File sizes after gzip:
4:46:25 PM:   101.39 KB  build/static/js/2.d4e8dc6a.chunk.js
4:46:25 PM:   28.66 KB   build/static/js/main.6894ecbf.chunk.js
4:46:25 PM:   3.9 KB     build/static/css/main.be9b4320.chunk.css
4:46:25 PM:   784 B      build/static/js/runtime-main.2776aaaa.js
4:46:25 PM: The project was built assuming it is hosted at /.
4:46:25 PM: You can control this with the homepage field in your package.json.
4:46:25 PM: The build folder is ready to be deployed.
4:46:25 PM: You may serve it with a static server:
4:46:25 PM:   yarn global add serve
4:46:25 PM:   serve -s build
4:46:25 PM: Find out more about deployment here:
4:46:25 PM:   https://cra.link/deployment
4:46:25 PM: Done in 12.43s.
4:46:25 PM: ​
4:46:25 PM: (build.command completed in 12.7s)
4:46:25 PM: ​
4:46:25 PM: ┌─────────────────────────────┐
4:46:25 PM: │   Netlify Build Complete    │
4:46:25 PM: └─────────────────────────────┘
4:46:25 PM: ​
4:46:25 PM: (Netlify Build completed in 12.8s)
4:46:25 PM: Caching artifacts
4:46:25 PM: Started saving node modules
4:46:25 PM: Finished saving node modules
4:46:25 PM: Started saving build plugins
4:46:25 PM: Finished saving build plugins
4:46:25 PM: Started saving yarn cache
4:46:25 PM: Finished saving yarn cache
4:46:25 PM: Started saving pip cache
4:46:25 PM: Finished saving pip cache
4:46:25 PM: Started saving emacs cask dependencies
4:46:25 PM: Finished saving emacs cask dependencies
4:46:25 PM: Started saving maven dependencies
4:46:25 PM: Finished saving maven dependencies
4:46:25 PM: Started saving boot dependencies
4:46:25 PM: Finished saving boot dependencies
4:46:25 PM: Started saving go dependencies
4:46:26 PM: Finished saving go dependencies
4:46:27 PM: Build script success
4:46:27 PM: Starting to deploy site from 'build'
4:46:27 PM: Creating deploy tree 
4:46:27 PM: Creating deploy upload records
4:46:27 PM: 4 new files to upload
4:46:27 PM: 0 new functions to upload
4:46:27 PM: Starting post processing
4:46:27 PM: Post processing - HTML
4:46:27 PM: Post processing - header rules
4:46:27 PM: Post processing - redirect rules
4:46:27 PM: Post processing done
4:46:28 PM: Site is live ✨
4:47:13 PM: Finished processing build request in 1m25.324340812s```

The better the post - the faster the answer.

Hi, both the links looks same to me, that is, I see a subscription form and no Google Play button. Seems like it’s all working fine now.

I ended up fixing this issue last night by doing a ‘clear cache and deploy’ a few times and suddenly it worked.

1 Like