Gatsby site builds fine, can see preview, but deploy url doesn't work: "Page not found"

site name:

I’m fairly new to this and may be missing something obvious, but I’ve succesfully pushed and ultimately deployed my basic gatsby site build several times now and when attempting to view via the url always receive a “page not found” error

Strangely, previewing the build by using the preview link above the build log renders the site fine:

The builds are definitely working, I have tested locally where I can clearly see an index.html is being built in root, the build preview link above works, and netlify is even rendering a thumbnail of my index.html in my dashboard.

Any leads on this one? Would much appreciate any support.

E: accessing via or works correctly, but still produces the error.

I’ve tried including a _redirects file with /* /index.html 200 but this doesn’t appear to achieve anything.

hi there, it seems to be working? Not sure what you did, but you seem to have fixed it!

what was the problem?

Thanks for confirming it works on your end - actually I just had a few people test for me with the same results.

Again, I’m not sure if my inexperience is showing here again, but of all the people I’ve had test this, they all work except those accessing from Australia. I’ve tried several tests across a few networks and devices here and still get Page not Found, and my colleagues in Aus always produce same result.

There was indeed a very naughty misbehaving CDN node in Sydney that caused this . Once I looked in the right way I could see the desync from the rest of our CDN, and our team repaired it and I’ve verified. Please let me know if your folks still see anything odd!

Thanks so much mate, this fixed everything!