Gatsby DSG stopped working

Our Gatsby DSG generated pages stopped working all of a sudden. Is this something to do with your upgrade to node 16? Tried setting node 16 in our .nvmrc file but it doesn’t fix it. Only solution was to disable DSG for now. Not ideal.

Hey there, @dmdevs :wave:

Thanks so much for reaching out-- sorry to hear you are encountering obstacles. Can you please share your site where this is happening? Additionally, could you please share your latest deploy log? I will share both of those with the appropriate team in order to look into this further.

Hey there, @dmdevs :wave:

In addition to sharing that information, can you try rolling back AWS_LAMBDA_JS_RUNTIME to nodejs14.x? Let us know if this works.

@hillary hi, AWS_LAMBDA RUNTIME did not help me.
I have been struggling with this problem for 2 days, please help me

https://precious-pastelito-4f7819.netlify.app/ssr-page - SSR_PAGE

Hey @ynherb299 , I’ve checked your site and it looks like you are not getting the same error that the original Forums member posted in their initial post – we’re seeing a TypeError on the function error page:

Typically, this kind of error indicates an issue in the code and not within Netlify. We suggest that you take a look in the code (likely in the place described in the stack trace shown in the above screenshot) for further debugging.

Hi, I also ran into the same issue for a Gatsby SSR generated page. We also set our node version to 16 in our .nvmrc. Screenshot of the error:

I set AWS_LAMBDA_JS_RUNTIME to nodejs14.x and re-deployed and the issue was fixed.

@hillary @amelia My question is why do we need to set this? Is this a temporary fix for now or would we have to keep this deploy environment variable going forward?

Thanks for the support!

Hello @winstonkim @ynherb299 and @dmdevs

We’ve made a couple of recent fixes on the latest version of the plugin (3.3.1)

Can you update to this version and try again, please?

Hi @gualter, I updated to that version and tried again and removed AWS_LAMBDA_JS_RUNTIME to nodejs14.x, but the same error appears now.

Preview url here: https://62d9842c2a683f09c8781003--curology-gatsby.netlify.app/free-trial/winston-test

:wave: @winstonkim

Can you please update Gatsby as well? Are you running the lastest version?